libfm: bump to version 1.3.0.2
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 29 Apr 2018 19:09:03 +0000 (21:09 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 30 Apr 2018 15:38:21 +0000 (17:38 +0200)
Add hash for license files

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libfm/0001-modules-fix-cross-compilation.patch [new file with mode: 0644]
package/libfm/libfm.hash
package/libfm/libfm.mk

diff --git a/package/libfm/0001-modules-fix-cross-compilation.patch b/package/libfm/0001-modules-fix-cross-compilation.patch
new file mode 100644 (file)
index 0000000..8b5f1cf
--- /dev/null
@@ -0,0 +1,27 @@
+From 3bc935b732d1ff448727e90340e4be40ef6fc000 Mon Sep 17 00:00:00 2001
+From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+Date: Sun, 29 Apr 2018 20:22:29 +0200
+Subject: [PATCH] modules: fix cross-compilation
+
+Do not add -L$(libdir) to AM_LDFLAGS
+
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+---
+ src/modules/Makefile.am | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/src/modules/Makefile.am b/src/modules/Makefile.am
+index e61f4e01..01c15bd4 100644
+--- a/src/modules/Makefile.am
++++ b/src/modules/Makefile.am
+@@ -11,7 +11,6 @@ AM_CPPFLAGS = \
+ # tell libtool we compile module not library
+ AM_LDFLAGS = \
+       -no-undefined -module -avoid-version -shared -export-dynamic \
+-      -L$(libdir) \
+       $(GIO_LIBS)
+ # the module should be linked only with libfm, not libfm-gtk or whatever
+-- 
+2.14.1
+
index 69c4c31f6debdd3d3441bef89069ecc0b3c48394..71befc355eb1c313ef548c6910160c5d65996f95 100644 (file)
@@ -1,3 +1,7 @@
 # From https://sourceforge.net/projects/pcmanfm/files/PCManFM%20%2B%20Libfm%20%28tarball%20release%29/LibFM/
-md5 a1ba9ae5e920f38b647dd511edd6c807  libfm-1.2.5.tar.xz
-sha1 5887aa4e85ee0964e7da67368136849957afd5d6  libfm-1.2.5.tar.xz
+md5 02a024714d51e0d37afc7bd596a44f3b  libfm-1.3.0.2.tar.xz
+sha1 aa7f73987866e557b74b8a28d0fea339d53899b6  libfm-1.3.0.2.tar.xz
+
+# Hash for license files:
+sha256 d8c320ffc0030d1b096ae4732b50d2b811cf95e9a9b7377c1127b2563e0a0388  COPYING
+sha256 c3a3d93e111462f2b0292b56a6a7b87d342fd7156741d8b81b8b08723be4597e  src/extra/fm-xml-file.c
index c49cd3e6333b0786a98b0c01aa05446487eaf5ff..292a0ab5d80ca61928bcaaee25ecaaddd4e45282 100644 (file)
@@ -4,13 +4,15 @@
 #
 ################################################################################
 
-LIBFM_VERSION = 1.2.5
+LIBFM_VERSION = 1.3.0.2
 LIBFM_SOURCE = libfm-$(LIBFM_VERSION).tar.xz
 LIBFM_SITE = http://sourceforge.net/projects/pcmanfm/files
 LIBFM_DEPENDENCIES = menu-cache libglib2 cairo
 LIBFM_LICENSE = GPL-2.0+, LGPL-2.1+
 LIBFM_LICENSE_FILES = COPYING src/extra/fm-xml-file.c
 LIBFM_INSTALL_STAGING = YES
+# We're patching src/modules/Makefile.am
+LIBFM_AUTORECONF = YES
 
 ifeq ($(BR2_PACKAGE_LIBEXIF),y)
 LIBFM_CONF_OPTS += --enable-exif