mpg123: bump to 1.20.0, providing better optimizations for ARM and AArch64
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 1 Jun 2014 13:11:24 +0000 (15:11 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 1 Jun 2014 19:51:17 +0000 (21:51 +0200)
As suggested by Gustavo, this patch bumps mpg123 to 1.20.0, and
therefore superseds the patch initially provided by Sven Neumann. In
1.20.0, there is a new CPU type arm_fpu, which will compile code for
both VFP and NEON, and choose at runtime which one to use.

Similarly for AArch64, the option --with-cpu=aarch64 will compile both
the NEON and generic decoders, and select at runtime which one to use.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mpg123/mpg123.mk

index d66592cd700d85d11dccb530acb08acd27a65bff..ac641326a9b32f47046f5c981f80bc9eac2c8860 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-MPG123_VERSION = 1.18.0
+MPG123_VERSION = 1.20.0
 MPG123_SOURCE = mpg123-$(MPG123_VERSION).tar.bz2
 MPG123_SITE = http://downloads.sourceforge.net/project/mpg123/mpg123/$(MPG123_VERSION)
 MPG123_CONF_OPT = --disable-lfs-alias
@@ -14,9 +14,17 @@ MPG123_LICENSE_FILES = COPYING
 
 MPG123_CPU = $(if $(BR2_SOFT_FLOAT),generic_nofpu,generic_fpu)
 
+ifeq ($(BR2_aarch64),y)
+MPG123_CPU = aarch64
+endif
+
 ifeq ($(BR2_arm),y)
+ifeq ($(or $(BR2_ARM_CPU_HAS_NEON),$(BR2_ARM_CPU_HAS_VFPV2)),y)
+MPG123_CPU = arm_fpu
+else
 MPG123_CPU = arm_nofpu
 endif
+endif
 
 ifeq ($(BR2_i386),y)
 MPG123_CPU = x86