pango: fix host build
authorPeter Korsgaard <jacmet@sunsite.dk>
Thu, 19 Mar 2009 11:07:10 +0000 (11:07 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 19 Mar 2009 11:07:10 +0000 (11:07 -0000)
pango likes to rerun it's configure script at make time, and it then
fails to find the correct pkg-config files (it finds the ones ins
STAGING_DIR) causing problems if they are not compatible.

Fix it by setting PKG_CONFIG_PATH in it's make environment.

package/pango/pango.mk

index b64d1a234fdfac3f723bba6c215c3407fbbcf5c1..40c9d2a066ec5911999e751a06275195363efd40 100644 (file)
@@ -88,7 +88,7 @@ $(STAMP_DIR)/host_pango_configured: $(STAMP_DIR)/host_pango_unpacked $(STAMP_DIR
        touch $@
 
 $(STAMP_DIR)/host_pango_compiled: $(STAMP_DIR)/host_pango_configured
-       $(HOST_MAKE_ENV) $(MAKE) -C $(PANGO_HOST_DIR)
+       $(HOST_MAKE_ENV) PKG_CONFIG_PATH="$(HOST_DIR)/usr/lib/pkgconfig$(PKG_CONFIG_PATH)" $(MAKE) -C $(PANGO_HOST_DIR)
        touch $@
 
 $(STAMP_DIR)/host_pango_installed: $(STAMP_DIR)/host_pango_compiled