gstreamer: fix build on AArch64 BE
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 30 Jun 2018 16:04:15 +0000 (18:04 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 30 Jun 2018 16:04:15 +0000 (18:04 +0200)
We recently enabled AArch64 big-endian testing in the autobuilders,
and gstreamer started failing because it does an AC_TRY_RUN() test to
check if unaligned accesses are allowed or not. We already handled the
AArch64 LE case, but not the AArch64 BE case, so let's handle it.

Fixes:

  http://autobuild.buildroot.net/results/b061948b04b42e753e52607f395ed7c597a52c68/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gstreamer/gstreamer/gstreamer.mk

index 91230aac28b553fea42110a8cabda71146e7dac1..88cc798828a1f4e6388adc2f0d3bd50f727b68d3 100644 (file)
@@ -18,7 +18,7 @@ GSTREAMER_LICENSE_FILES = COPYING
 ifeq ($(BR2_arc)$(BR2_xtensa)$(BR2_microblaze)$(BR2_nios2)$(BR2_or1k),y)
 GSTREAMER_CONF_ENV = as_cv_unaligned_access=no
 endif
-ifeq ($(BR2_aarch64),y)
+ifeq ($(BR2_aarch64)$(BR2_aarch64_be),y)
 GSTREAMER_CONF_ENV = as_cv_unaligned_access=yes
 endif