package/libdrm: bump version to 2.4.69
authorBernd Kuhls <bernd.kuhls@t-online.de>
Thu, 21 Jul 2016 19:07:19 +0000 (21:07 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 23 Jul 2016 12:41:49 +0000 (14:41 +0200)
Removed patch 0002, applied upstream:
https://cgit.freedesktop.org/mesa/drm/commit/xf86drm.c?id=4031dc17bb728850c9b079c8d5f9cc0a379b9d46

Renumbered patch 0003.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libdrm/0002-xf86atomic-require-CAS-support-in-libatomic_ops.patch [new file with mode: 0644]
package/libdrm/0002-xf86drm.c-Include-limits.h-to-fix-build-error-on-Sol.patch [deleted file]
package/libdrm/0003-xf86atomic-require-CAS-support-in-libatomic_ops.patch [deleted file]
package/libdrm/libdrm.hash
package/libdrm/libdrm.mk

diff --git a/package/libdrm/0002-xf86atomic-require-CAS-support-in-libatomic_ops.patch b/package/libdrm/0002-xf86atomic-require-CAS-support-in-libatomic_ops.patch
new file mode 100644 (file)
index 0000000..ff920fb
--- /dev/null
@@ -0,0 +1,32 @@
+From 7384f79f69fdb7b691cc5b0c28c301b3fe8b633e Mon Sep 17 00:00:00 2001
+From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+Date: Thu, 26 May 2016 10:46:57 +0200
+Subject: [PATCH] xf86atomic: require CAS support in libatomic_ops
+
+Since AO_compare_and_swap_full() is used by libdrm, AO_REQUIRE_CAS
+must be defined before including <atomic_ops.h> so that we are sure
+that CAS support will be provided. This is necessary to make sure that
+the AO_compare_and_swap_full() function will be provided on all
+architectures, including the ones that don't have built-in CAS support
+such as SPARCv8.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+---
+ xf86atomic.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/xf86atomic.h b/xf86atomic.h
+index 922b37d..d7017a5 100644
+--- a/xf86atomic.h
++++ b/xf86atomic.h
+@@ -58,6 +58,7 @@ typedef struct {
+ #endif
+ #if HAVE_LIB_ATOMIC_OPS
++#define AO_REQUIRE_CAS
+ #include <atomic_ops.h>
+ #define HAS_ATOMIC_OPS 1
+-- 
+2.7.4
+
diff --git a/package/libdrm/0002-xf86drm.c-Include-limits.h-to-fix-build-error-on-Sol.patch b/package/libdrm/0002-xf86drm.c-Include-limits.h-to-fix-build-error-on-Sol.patch
deleted file mode 100644 (file)
index 03b4524..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-From 3fed80daf1dcb0b5d20e623d27228726c735e138 Mon Sep 17 00:00:00 2001
-From: Bernd Kuhls <bernd.kuhls@t-online.de>
-Date: Sun, 27 Sep 2015 19:09:47 +0200
-Subject: [PATCH 1/1] xf86drm.c: Include limits.h to fix build error on Solaris
- and with musl
-
-musl's strict implementation requires #include <limits.h> for PATH_MAX.
-
-Patch suggested by evgeny for Solaris:
-https://bugs.freedesktop.org/show_bug.cgi?id=92082
-
-Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
----
- xf86drm.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/xf86drm.c b/xf86drm.c
-index a9f5c29..ec985eb 100644
---- a/xf86drm.c
-+++ b/xf86drm.c
-@@ -53,6 +53,7 @@
- #include <sys/ioctl.h>
- #include <sys/time.h>
- #include <stdarg.h>
-+#include <limits.h>
- #ifdef HAVE_SYS_MKDEV_H
- # include <sys/mkdev.h> /* defines major(), minor(), and makedev() on Solaris */
- #endif
--- 
-2.5.3
-
diff --git a/package/libdrm/0003-xf86atomic-require-CAS-support-in-libatomic_ops.patch b/package/libdrm/0003-xf86atomic-require-CAS-support-in-libatomic_ops.patch
deleted file mode 100644 (file)
index ff920fb..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-From 7384f79f69fdb7b691cc5b0c28c301b3fe8b633e Mon Sep 17 00:00:00 2001
-From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-Date: Thu, 26 May 2016 10:46:57 +0200
-Subject: [PATCH] xf86atomic: require CAS support in libatomic_ops
-
-Since AO_compare_and_swap_full() is used by libdrm, AO_REQUIRE_CAS
-must be defined before including <atomic_ops.h> so that we are sure
-that CAS support will be provided. This is necessary to make sure that
-the AO_compare_and_swap_full() function will be provided on all
-architectures, including the ones that don't have built-in CAS support
-such as SPARCv8.
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
----
- xf86atomic.h | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/xf86atomic.h b/xf86atomic.h
-index 922b37d..d7017a5 100644
---- a/xf86atomic.h
-+++ b/xf86atomic.h
-@@ -58,6 +58,7 @@ typedef struct {
- #endif
- #if HAVE_LIB_ATOMIC_OPS
-+#define AO_REQUIRE_CAS
- #include <atomic_ops.h>
- #define HAS_ATOMIC_OPS 1
--- 
-2.7.4
-
index 8bd3d95f373f12bfd54c811e0c17b36d6be1405b..3cfa34e35c9668679f9fd9b443522dedb66dfc88 100644 (file)
@@ -1,2 +1,2 @@
-# From https://lists.freedesktop.org/archives/dri-devel/2016-April/106211.html
-sha256 5b4bd9a5922929bc716411cb74061fbf31b06ba36feb89bc1358a91a8d0ca9df        libdrm-2.4.68.tar.bz2
+# From https://lists.x.org/archives/xorg-announce/2016-July/002700.html
+sha256 09510cbc75adba7e84fd3ec86586fd352a787fd534a63377de9e19ff85280b33        libdrm-2.4.69.tar.bz2
index 50fa7ef92f08e6ab71d4fe05509e7ff7311e3617..8fedfe6bd4e8d4a6b3dba2da9ae1b78ea7f74fbd 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-LIBDRM_VERSION = 2.4.68
+LIBDRM_VERSION = 2.4.69
 LIBDRM_SOURCE = libdrm-$(LIBDRM_VERSION).tar.bz2
 LIBDRM_SITE = http://dri.freedesktop.org/libdrm
 LIBDRM_LICENSE = MIT