binutils: ensure TARGET_CONFIGURE_ARGS is taken into consideration for subdirs
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Feb 2016 22:42:35 +0000 (23:42 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Feb 2016 22:46:45 +0000 (23:46 +0100)
Binutils runs the configure scripts of subdirs at make time, so we need a
custom build command to ensure TARGET_CONFIGURE_ARGS are taken into
consideration for those (E.G. for musl gettext handling).

Reported-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/binutils/binutils.mk

index 7c5955e25cf12aa18ddc105696c61158fd4e7cf9..a3e27be208ca83289588632ba2628d74cf2d0db4 100644 (file)
@@ -74,6 +74,12 @@ HOST_BINUTILS_CONF_OPTS = \
        $(BINUTILS_DISABLE_GDB_CONF_OPTS) \
        $(BINUTILS_EXTRA_CONFIG_OPTIONS)
 
+# binutils run configure script of subdirs at make time, so ensure
+# our TARGET_CONFIGURE_ARGS are taken into consideration for those
+define BINUTILS_BUILD_CMDS
+       $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_ARGS) $(MAKE) -C $(@D)
+endef
+
 # We just want libbfd, libiberty and libopcodes,
 # not the full-blown binutils in staging
 define BINUTILS_INSTALL_STAGING_CMDS