package/python-pyqt5: fix QtLocation module dependency
authorPeter Seiderer <ps.report@gmx.net>
Sat, 16 May 2020 11:26:08 +0000 (13:26 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 16 May 2020 11:44:46 +0000 (13:44 +0200)
The QT module location from qt5location depends on
QT quick from qt5declarative.

>From qt5location-5.14.2/src/src.pro:

  qtHaveModule(quick) {
      SUBDIRS += positioningquick location
      ...
  }

Adjust pyqt5 QtLocation module dependency accordingly.

Fixes:

  - http://autobuild.buildroot.net/results/122bb0a37d968cd79dc043b48f90f1ba4135491f

  Reading .../build/python-pyqt5-5.7/QtLocation/QtLocation.pro
  Project ERROR: Unknown module(s) in QT: location

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/python-pyqt5/python-pyqt5.mk

index 260a93af9c3edf61d9d9731d8eef415d8617f12f..9b5e9089fc99d5ed67cee346f51f80d394271136 100644 (file)
@@ -65,7 +65,10 @@ endif
 
 ifeq ($(BR2_PACKAGE_QT5LOCATION),y)
 PYTHON_PYQT5_DEPENDENCIES += qt5location
-PYTHON_PYQT5_MODULES += QtLocation QtPositioning
+PYTHON_PYQT5_MODULES += QtPositioning
+ifeq ($(BR2_PACKAGE_QT5DECLARATIVE_QUICK),y)
+PYTHON_PYQT5_MODULES += QtLocation
+endif
 endif
 
 ifeq ($(BR2_PACKAGE_QT5MULTIMEDIA),y)