imx-gpu-viv: fix build dependencies when linking against libGAL.so
authorAntoine Ténart <antoine.tenart@free-electrons.com>
Tue, 1 Mar 2016 12:39:46 +0000 (13:39 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 1 Mar 2016 16:46:52 +0000 (17:46 +0100)
Packages like QT5 Base with OpenGL and X support link against libGAL.so
at build time. This results in an error because some X functions used
in libGAL.so aren't referenced as the libXdamage, libXext and libXfixes
packages aren't built and installed into sysroot at the time. Fix this
by adding these three packages as build dependencies of imx-gpu-viv.

Signed-off-by: Antoine Tenart <antoine.tenart@free-electrons.com>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/freescale-imx/imx-gpu-viv/Config.in
package/freescale-imx/imx-gpu-viv/imx-gpu-viv.mk

index 1c00eaa8c65832e4f70f9cdfca2c09586926aa3d..c386765396094982e4474891c748a8b6ab4e36dd 100644 (file)
@@ -33,8 +33,9 @@ choice
 config BR2_PACKAGE_IMX_GPU_VIV_OUTPUT_X11
        bool "X11"
        depends on BR2_PACKAGE_XORG7
-       select BR2_PACKAGE_XLIB_LIBXDAMAGE # Runtime dependency
-       select BR2_PACKAGE_XLIB_LIBXEXT # Runtime dependency
+       select BR2_PACKAGE_XLIB_LIBXDAMAGE
+       select BR2_PACKAGE_XLIB_LIBXEXT
+       select BR2_PACKAGE_XLIB_LIBXFIXES
 
 comment "X11 backend needs Xorg package"
        depends on !BR2_PACKAGE_XORG7
index 133632b403c7791d6150e94b40e34cb60b49b0a2..61710804b79135b8a75165e1c3472fbe216d7744 100644 (file)
@@ -22,6 +22,14 @@ IMX_GPU_VIV_REDISTRIBUTE = NO
 IMX_GPU_VIV_PROVIDES = libegl libgles libopenvg
 IMX_GPU_VIV_LIB_TARGET = $(call qstrip,$(BR2_PACKAGE_IMX_GPU_VIV_OUTPUT))
 
+ifeq ($(IMX_GPU_VIV_LIB_TARGET),x11)
+# The libGAL.so library provided by imx-gpu-viv uses X functions. Packages
+# may want to link against libGAL.so (QT5 Base with OpenGL and X support
+# does so). For this to work we need build dependencies to libXdamage,
+# libXext and libXfixes so that X functions used in libGAL.so are referenced.
+IMX_GPU_VIV_DEPENDENCIES += xlib_libXdamage xlib_libXext xlib_libXfixes
+endif
+
 define IMX_GPU_VIV_EXTRACT_CMDS
        $(call FREESCALE_IMX_EXTRACT_HELPER,$(DL_DIR)/$(IMX_GPU_VIV_SOURCE))
 endef