localedef: new package
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 8 May 2012 04:39:21 +0000 (04:39 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 8 May 2012 22:25:58 +0000 (00:25 +0200)
This host only package allows to build the localedef program, which is
needed to generate locale data for (e)glibc-based systems. The source
code has been extracted from the eglibc sources and put inside a small
and nice tarball by the PTXdist developers, which makes it easy and
convenient to build for the host.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/localedef/localedef.mk [new file with mode: 0644]

diff --git a/package/localedef/localedef.mk b/package/localedef/localedef.mk
new file mode 100644 (file)
index 0000000..1a044e3
--- /dev/null
@@ -0,0 +1,20 @@
+#############################################################
+#
+# localedef
+#
+#############################################################
+
+LOCALEDEF_VERSION = 2.14.1-r17443-ptx1
+LOCALEDEF_SOURCE  = localedef-eglibc-$(LOCALEDEF_VERSION).tar.bz2
+LOCALEDEF_SITE    = http://www.pengutronix.de/software/ptxdist/temporary-src/
+
+HOST_LOCALEDEF_CONF_OPT += \
+       --prefix=/usr \
+       --with-glibc=./eglibc
+
+# The makefile does not implement an install target
+define HOST_LOCALEDEF_INSTALL_CMDS
+       $(INSTALL) -D -m 0755 $(@D)/localedef $(HOST_DIR)/usr/bin/localedef
+endef
+
+$(eval $(call AUTOTARGETS,host))