package/python-channels: new package
authorAdam Duskett <Aduskett@gmail.com>
Sun, 4 Aug 2019 01:16:30 +0000 (21:16 -0400)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 30 Sep 2019 19:44:47 +0000 (21:44 +0200)
Channels augments Django to bring WebSocket, long-poll HTTP, task
offloading and other async support to your code, using familiar Django
design patterns and a flexible underlying framework that lets you not
only customize behaviours but also write support for your own
protocols and needs.

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
[Thomas:
 - alphabetic ordering of selects in Config.in
 - add missing BR2_PACKAGE_PYTHON3 dependency]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/python-channels/Config.in [new file with mode: 0644]
package/python-channels/python-channels.hash [new file with mode: 0644]
package/python-channels/python-channels.mk [new file with mode: 0644]

index 71b1b2b6eb5550a2a79cbe173288ea1a421717a4..78538f10b969c2cf80237a9b4503b0166dc5684d 100644 (file)
@@ -56,6 +56,7 @@ F:    package/policycoreutils/
 F:     package/python3/
 F:     package/python-aioredis/
 F:     package/python-asgiref/
+F:     package/python-channels/
 F:     package/python-daphne/
 F:     package/python-django-enumfields/
 F:     package/python-flask-sqlalchemy/
index 91f5bb736d4ed30f17d55f082ead4212e9203f02..5324220f297373f95a938547d302b4c8a482f124 100644 (file)
@@ -853,6 +853,7 @@ menu "External python modules"
        source "package/python-cchardet/Config.in"
        source "package/python-certifi/Config.in"
        source "package/python-cffi/Config.in"
+       source "package/python-channels/Config.in"
        source "package/python-characteristic/Config.in"
        source "package/python-chardet/Config.in"
        source "package/python-cheetah/Config.in"
diff --git a/package/python-channels/Config.in b/package/python-channels/Config.in
new file mode 100644 (file)
index 0000000..45c9dcc
--- /dev/null
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_PYTHON_CHANNELS
+       bool "python-channels"
+       depends on BR2_PACKAGE_PYTHON3 # python-daphne
+       select BR2_PACKAGE_PYTHON_ASGIREF # runtime
+       select BR2_PACKAGE_PYTHON_DAPHNE # runtime
+       select BR2_PACKAGE_PYTHON_DJANGO # runtime
+       help
+         Channels augments Django to bring WebSocket, long-poll
+         HTTP, task offloading and other async support to your
+         code, using familiar Django design patterns and a
+         flexible underlying framework that lets you not only
+         customize behaviours but also write support for your
+         own protocols and needs.
+
+         http://github.com/django/channels
diff --git a/package/python-channels/python-channels.hash b/package/python-channels/python-channels.hash
new file mode 100644 (file)
index 0000000..539589e
--- /dev/null
@@ -0,0 +1,5 @@
+# md5, sha256 from https://pypi.org/pypi/channels/json
+md5    aec056cf4d0fa6444b3d83ccd5885fc5  channels-2.2.0.tar.gz
+sha256 af7cdba9efb3f55b939917d1b15defb5d40259936013e60660e5e9aff98db4c5  channels-2.2.0.tar.gz
+# Locally computed sha256 checksums
+sha256 b846415d1b514e9c1dff14a22deb906d794bc546ca6129f950a18cd091e2a669  LICENSE
diff --git a/package/python-channels/python-channels.mk b/package/python-channels/python-channels.mk
new file mode 100644 (file)
index 0000000..a0f4591
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-channels
+#
+################################################################################
+
+PYTHON_CHANNELS_VERSION = 2.2.0
+PYTHON_CHANNELS_SOURCE = channels-$(PYTHON_CHANNELS_VERSION).tar.gz
+PYTHON_CHANNELS_SITE = https://files.pythonhosted.org/packages/26/b9/92c803f3e8e304efbfbcd0634d4a5ad2d231f515b968f1b9e7c84ee78012
+PYTHON_CHANNELS_SETUP_TYPE = setuptools
+PYTHON_CHANNELS_LICENSE = BSD-3-Clause
+PYTHON_CHANNELS_LICENSE_FILES = LICENSE
+
+$(eval $(python-package))