package/freescale-imx/imx-gpu-viv: drop pkg-config files installation
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 5 Aug 2021 21:27:33 +0000 (23:27 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 20 Aug 2021 21:37:39 +0000 (23:37 +0200)
We manually install pkg-config files from
$(@D)/gpu-core/usr/lib/pkgconfig to the STAGING_DIR right after
copying the entire $(@D)/gpu-core/usr/* files to STAGING_DIR. This
makes the manual copying of pkg-config files pretty useless.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Reviewed-by: Gary Bisson <gary.bisson@boundarydevices.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/freescale-imx/imx-gpu-viv/imx-gpu-viv.mk

index 51b04f82d491bd73f550b435f912ba985df99b26..9d974cac41c9c359f96d90417302924434afe88f 100644 (file)
@@ -75,11 +75,6 @@ endef
 
 define IMX_GPU_VIV_INSTALL_STAGING_CMDS
        cp -r $(@D)/gpu-core/usr/* $(STAGING_DIR)/usr
-       for lib in egl gbm glesv1_cm glesv2 vg; do \
-               $(INSTALL) -m 0644 -D \
-                       $(@D)/gpu-core/usr/lib/pkgconfig/$${lib}.pc \
-                       $(STAGING_DIR)/usr/lib/pkgconfig/$${lib}.pc; \
-       done
 endef
 
 ifeq ($(BR2_PACKAGE_IMX_GPU_VIV_EXAMPLES),y)