package/upx: use HOST_CONFIGURE_OPTS
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 6 Jun 2020 19:20:32 +0000 (21:20 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 6 Jun 2020 19:23:51 +0000 (21:23 +0200)
Use HOST_CONFIGURE_OPTS to pass CPPFLAGS and LDFLAGS

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/upx/upx.mk

index 1fe7162c21f18ba7cc262fcc7eab21b6301ab0df..c554553ce9d3dd37693862ea08d267fd10ed8429 100644 (file)
@@ -15,10 +15,8 @@ HOST_UPX_DEPENDENCIES = host-ucl host-zlib
 # We need to specify all, otherwise the default target only prints a message
 # stating to "please choose a target for 'make'"... :-(
 define HOST_UPX_BUILD_CMDS
-       $(HOST_MAKE_ENV) $(MAKE) CPPFLAGS="$(HOST_CPPFLAGS)" \
-               LDFLAGS="$(HOST_LDFLAGS)" UPX_UCLDIR=$(HOST_DIR) \
-               CXXFLAGS_WERROR= \
-               -C $(@D) all
+       $(HOST_MAKE_ENV) $(HOST_CONFIGURE_OPTS) $(MAKE) \
+               UPX_UCLDIR=$(HOST_DIR) CXXFLAGS_WERROR= -C $(@D) all
 endef
 
 # UPX has no install procedure, so install it manually.