package/linux-firmware: add option for Broadcom Tigon3 ethernet cards
authorPeter Seiderer <ps.report@gmx.net>
Mon, 23 Nov 2020 22:11:39 +0000 (23:11 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 2 Jan 2021 12:57:13 +0000 (13:57 +0100)
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/linux-firmware/Config.in
package/linux-firmware/linux-firmware.mk

index 6d5e96152776a6c16ec206196bdf0164840faa9f..8e71c212510508a723c026dade9a0094e9a78d46 100644 (file)
@@ -380,6 +380,12 @@ endmenu
 
 menu "Ethernet firmware"
 
+config BR2_PACKAGE_LINUX_FIRMWARE_BROADCOM_TIGON3
+       bool "Broadcom NetXtreme/Tigon3"
+       help
+         Firmware files for Broadcom Tigon3 ethernet cards
+         (tigon)
+
 config BR2_PACKAGE_LINUX_FIRMWARE_BNX2X
        bool "Broadcom NetXtremeII"
        help
index dbcf135f263f8db2aceaa71f395e316273f9eaf0..92d03624f5d923cacc5fc36db5a3c38a76767c4f 100644 (file)
@@ -461,6 +461,12 @@ LINUX_FIRMWARE_FILES += iwlwifi-9???-*.ucode
 LINUX_FIRMWARE_ALL_LICENSE_FILES += LICENCE.iwlwifi_firmware
 endif
 
+ifeq ($(BR2_PACKAGE_LINUX_FIRMWARE_BROADCOM_TIGON3),y)
+LINUX_FIRMWARE_FILES += tigon/*
+# No license file; the license is in the file WHENCE
+# which is installed unconditionally
+endif
+
 ifeq ($(BR2_PACKAGE_LINUX_FIRMWARE_BNX2X),y)
 LINUX_FIRMWARE_FILES += bnx2x/*
 # No license file; the license is in the file WHENCE