zlib: remove dedicated target-headers option
authorPeter Korsgaard <jacmet@sunsite.dk>
Sat, 3 Oct 2009 21:03:05 +0000 (23:03 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 3 Oct 2009 21:03:05 +0000 (23:03 +0200)
Instead, simply only copy headers/static lib if BR2_HAVE_DEVFILES
is enabled.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/zlib/Config.in
package/zlib/zlib.mk

index eeda15e16422c4ea22754e8b3548b287338f5b09..8954214242da53d34dfc4ddb3bf9a6647819fa87 100644 (file)
@@ -5,9 +5,3 @@ config BR2_PACKAGE_ZLIB
          gzip and libpng.
 
          http://www.gzip.org/zlib/
-
-config BR2_PACKAGE_ZLIB_TARGET_HEADERS
-       bool "zlib headers in target"
-       depends on BR2_PACKAGE_ZLIB
-       help
-         Put headers files in the target.
index a67a5e830f1365eac743ea5d073323c3179d0e28..9131832f9bd70f23e56a211e82b4033a562fa252 100644 (file)
@@ -68,9 +68,7 @@ $(TARGET_DIR)/usr/lib/libz.a: $(STAGING_DIR)/usr/lib/libz.a
        $(INSTALL) -D $(STAGING_DIR)/usr/lib/libz.a $(TARGET_DIR)/usr/lib/libz.a
        touch -c $@
 
-zlib-headers: $(TARGET_DIR)/usr/lib/libz.a
-
-zlib: $(ZLIB_TARGET)
+zlib: $(ZLIB_TARGET) $(if $(BR2_HAVE_DEVFILES,$(TARGET_DIR)/usr/lib/libz.a)
 
 zlib-source: $(DL_DIR)/$(ZLIB_SOURCE)
 
@@ -94,6 +92,3 @@ zlib-dirclean:
 ifeq ($(BR2_PACKAGE_ZLIB),y)
 TARGETS+=zlib
 endif
-ifeq ($(BR2_PACKAGE_ZLIB_TARGET_HEADERS),y)
-TARGETS+=zlib-headers
-endif