boost: fix handling of BR2_PACKAGE_BOOST_FIBER option
authorAdam Duskett <aduskett@gmail.com>
Fri, 3 Nov 2017 13:27:50 +0000 (09:27 -0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 3 Nov 2017 17:47:50 +0000 (18:47 +0100)
Commit 657dbfa00af724c2539a08eaaf0c8044dd4051d7 ("boost: add fiber
module"), introduced:

BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_FILESYSTEM),,fiber)

which obviously is a typo, and should have been:

BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_FIBER),,fiber)

Due to this, the fiber module gets compiled even if
BR2_PACKAGE_BOOST_FIBER is disabled, causing build failures when NPTL
is not available (the fiber library needs NPTL threads).

Fixes:

  http://autobuild.buildroot.net/results/c8b58bf37b565e7a4dd7959e0d9c1cec993758ba/
  http://autobuild.buildroot.net/results/df6f9d51ee766a6f8fca986cdc7476d148dad53e/
  http://autobuild.buildroot.net/results/fecc16df052ac5b14d3b15e174c7026dfcc8fd33/

Signed-off-by: Adam Duskett <aduskett@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/boost/boost.mk

index 750b40f7d22a492545c72ef0855e90603b1a75db..864a07f7894219e181cd8c97df1b2d4f5459ef2b 100644 (file)
@@ -26,7 +26,7 @@ BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_CONTEXT),,context)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_COROUTINE),,coroutine)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_DATE_TIME),,date_time)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_EXCEPTION),,exception)
-BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_FILESYSTEM),,fiber)
+BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_FIBER),,fiber)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_FILESYSTEM),,filesystem)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_GRAPH),,graph)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_GRAPH_PARALLEL),,graph_parallel)