package/lua-cqueues: needs host-m4
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 11 Dec 2018 16:13:44 +0000 (17:13 +0100)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 11 Dec 2018 22:08:03 +0000 (23:08 +0100)
The lua-cqueues build system uses m4 during the build:

cd /home/test/autobuild/run/instance-1/output/build/lua-cqueues-rel-20161215/src && m4 /home/test/autobuild/run/instance-1/output/build/lua-cqueues-rel-20161215/src/errno.c.m4 >| /home/test/autobuild/run/instance-1/output/build/lua-cqueues-rel-20161215/src/errno.c.tmp

Therefore, the package should depend on host-m4. This has been
detected using per-package directory support, but a minimal defconfig
with just lua and lua-cqueues on a system that doesn't have m4
installed system-wide also exhibits the issue.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/lua-cqueues/lua-cqueues.mk

index 4f4be1e0494c666fe3e01bd94f827e0ee561ebc6..4f31c3277ffee73d4681e31a99d710255ec42406 100644 (file)
@@ -8,7 +8,7 @@ LUA_CQUEUES_VERSION = rel-20161215
 LUA_CQUEUES_SITE = $(call github,wahern,cqueues,$(LUA_CQUEUES_VERSION))
 LUA_CQUEUES_LICENSE = MIT
 LUA_CQUEUES_LICENSE_FILES = LICENSE
-LUA_CQUEUES_DEPENDENCIES = luainterpreter openssl
+LUA_CQUEUES_DEPENDENCIES = luainterpreter openssl host-m4
 
 define LUA_CQUEUES_BUILD_CMDS
        $(TARGET_MAKE_ENV) $(MAKE1) $(TARGET_CONFIGURE_OPTS) -C $(@D) \