libtasn1: bump to version 4.9
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 10 Aug 2016 02:31:04 +0000 (23:31 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 10 Aug 2016 22:03:45 +0000 (00:03 +0200)
Add upstream patch to fix build failure with gcc warnings on.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libtasn1/0001-configure-don-t-add-Werror-to-build-flags.patch [new file with mode: 0644]
package/libtasn1/libtasn1.hash
package/libtasn1/libtasn1.mk

diff --git a/package/libtasn1/0001-configure-don-t-add-Werror-to-build-flags.patch b/package/libtasn1/0001-configure-don-t-add-Werror-to-build-flags.patch
new file mode 100644 (file)
index 0000000..387ba7a
--- /dev/null
@@ -0,0 +1,28 @@
+From dd091c8af163213e12aa92f61bc4916e0f102633 Mon Sep 17 00:00:00 2001
+From: Nikos Mavrogiannopoulos <nmav@redhat.com>
+Date: Tue, 26 Jul 2016 08:45:33 +0200
+Subject: [PATCH] configure: don't add -Werror to build flags
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+---
+Patch status: upstream
+
+ configure.ac | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 7a14e04..066f5fe 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -70,8 +70,6 @@ AC_ARG_ENABLE([gcc-warnings],
+ )
+ if test "$gl_gcc_warnings" = yes; then
+-  gl_WARN_ADD([-Werror], [WERROR_CFLAGS])
+-
+   nw="$nw -Wsystem-headers"         # Don't let system headers trigger warnings
+   nw="$nw -Wc++-compat"             # We don't care strongly about C++ compilers
+   nw="$nw -Wtraditional"            # Warns on #elif which we use often
+-- 
+2.7.3
+
index dc65210387060f681f7bea5d390593d1e986d963..5b2100e87d9089124edab36303ec479d4106f67d 100644 (file)
@@ -1,2 +1,2 @@
 # Locally calculated after checking pgp signature
-sha256 fa802fc94d79baa00e7397cedf29eb6827d4bd8b4dd77b577373577c93a8c513        libtasn1-4.8.tar.gz
+sha256 4f6f7a8fd691ac2b8307c8ca365bad711db607d4ad5966f6938a9d2ecd65c920        libtasn1-4.9.tar.gz
index c51d8c0072936006775411032958bba7bf99128f..6b7e6b336444a41a2c5e822f300f403e605213e1 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-LIBTASN1_VERSION = 4.8
+LIBTASN1_VERSION = 4.9
 LIBTASN1_SITE = http://ftp.gnu.org/gnu/libtasn1
 LIBTASN1_DEPENDENCIES = host-bison
 LIBTASN1_LICENSE = GPLv3+, LGPLv2.1+
@@ -12,5 +12,7 @@ LIBTASN1_LICENSE_FILES = COPYING COPYING.LIB
 LIBTASN1_INSTALL_STAGING = YES
 # 'missing' fallback logic botched so disable it completely
 LIBTASN1_CONF_ENV = MAKEINFO="true"
+# For 0001-configure-don-t-add-Werror-to-build-flags.patch
+LIBTASN1_AUTORECONF = YES
 
 $(eval $(autotools-package))