gpu-viv-bin-mx6q: remove useless build time deps
authorJérôme Pouiller <jezz@sysmic.org>
Thu, 30 Apr 2015 15:12:19 +0000 (17:12 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 1 May 2015 20:57:18 +0000 (22:57 +0200)
Since gpu-viv-bin-mx6q is provided as binary package, there is no build
time dependencies.

Tested-by: Gary Bisson <gary.bisson@boundarydevices.com>
Reviewed-by: Gary Bisson <gary.bisson@boundarydevices.com>
Signed-off-by: Jérôme Pouiller <jezz@sysmic.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/freescale-imx/gpu-viv-bin-mx6q/Config.in
package/freescale-imx/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.mk

index c770346c71eddd3542440436eb5227364f2017aa..96113798aef2c351ec3d42f46e4f972c2d001f67 100644 (file)
@@ -33,8 +33,8 @@ choice
 config BR2_PACKAGE_GPU_VIV_BIN_MX6Q_OUTPUT_X11
        bool "X11"
        depends on BR2_PACKAGE_XORG7
-       select BR2_PACKAGE_XLIB_LIBXDAMAGE
-       select BR2_PACKAGE_XLIB_LIBXEXT
+       select BR2_PACKAGE_XLIB_LIBXDAMAGE # Runtime dependency
+       select BR2_PACKAGE_XLIB_LIBXEXT # Runtime dependency
 
 comment "X11 backend needs Xorg package"
        depends on !BR2_PACKAGE_XORG7
index f96087b41157d14556d5d0915ebcda9bb7a0f519..6221ee5782393c20438c7bcff98cb980e9a25481 100644 (file)
@@ -22,7 +22,6 @@ GPU_VIV_BIN_MX6Q_PROVIDES = libegl libgles libopenvg
 
 # DirectFB is not supported (wrong version)
 ifeq ($(BR2_PACKAGE_GPU_VIV_BIN_MX6Q_OUTPUT_X11),y)
-GPU_VIV_BIN_MX6Q_DEPENDENCIES = xlib_libXdamage xlib_libXext
 GPU_VIV_BIN_MX6Q_LIB_TARGET = x11
 else
 GPU_VIV_BIN_MX6Q_LIB_TARGET = fb