elftosb: use HOST_CONFIGURE_OPTS instead of HOST_MAKE_ENV
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 22 Jul 2012 18:29:50 +0000 (20:29 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 22 Jul 2012 18:29:50 +0000 (20:29 +0200)
HOST_CONFIGURE_OPTS allows to pass the correct CC, CXX, CFLAGS,
CXXFLAGS, etc. For example, it allows the elftosb build process to
properly use ccache when available.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/elftosb/elftosb.mk

index b2e50f72f2df647423f290e2da81f1488bde492c..5803b759285d30eff1854cdaf243dbf1d7da3832 100644 (file)
@@ -8,7 +8,7 @@ ELFTOSB_SOURCE = elftosb-$(ELFTOSB_VERSION).tar.gz
 ELFTOSB_SITE = http://repository.timesys.com/buildsources/e/elftosb/elftosb-$(ELFTOSB_VERSION)
 
 define HOST_ELFTOSB_BUILD_CMDS
-       $(HOST_MAKE_ENV) $(MAKE) -C $(@D) all
+       $(HOST_CONFIGURE_OPTS) $(MAKE) -C $(@D) all
 endef
 
 define HOST_ELFTOSB_INSTALL_CMDS