package/apr-util: add optional support for postgresql
authorBernd Kuhls <bernd.kuhls@t-online.de>
Fri, 4 May 2018 18:26:14 +0000 (20:26 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 8 May 2018 13:26:53 +0000 (15:26 +0200)
apr-util contains optional support for postgresql:

$ ls -1 output/target/usr/lib/apr-util-1/apr_dbd_pg*
output/target/usr/lib/apr-util-1/apr_dbd_pgsql-1.so
output/target/usr/lib/apr-util-1/apr_dbd_pgsql.la
output/target/usr/lib/apr-util-1/apr_dbd_pgsql.so

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/apr-util/apr-util.mk

index c44cef009f82b6e41655e912ec71814abf3e3c5c..22f1913865f82c2d465b7f18a30a6c2aca07a509 100644 (file)
@@ -54,6 +54,13 @@ else
 APR_UTIL_CONF_OPTS += --without-crypto
 endif
 
+ifeq ($(BR2_PACKAGE_POSTGRESQL),y)
+APR_UTIL_CONF_OPTS += --with-pgsql="$(STAGING_DIR)/usr"
+APR_UTIL_DEPENDENCIES += postgresql
+else
+APR_UTIL_CONF_OPTS += --without-pgsql
+endif
+
 ifeq ($(BR2_PACKAGE_UNIXODBC),y)
 APR_UTIL_CONF_OPTS += --with-odbc="$(STAGING_DIR)/usr"
 # avoid using target binary $(STAGING_DIR)/usr/bin/odbc_config