qt: add option for enabling the accessibility support
authorRomain Perier <romain.perier@free-electrons.com>
Tue, 12 Jul 2016 09:30:19 +0000 (11:30 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 15 Jul 2016 13:06:40 +0000 (15:06 +0200)
This adds an entry in the configuration menu in order to enable or
disable the accessibility support.

Signed-off-by: Romain Perier <romain.perier@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/qt/Config.in
package/qt/qt.mk

index 0fa24248429c68c1419ef415c4d5a8f9bd91f86a..548d180636f274b748835b424ad85fcd6be35c5e 100644 (file)
@@ -302,6 +302,11 @@ config BR2_PACKAGE_QT_QTTIFF
        bool "Use Qt bundled libtiff"
 endchoice
 
+config BR2_PACKAGE_QT_ACCESSIBILITY
+       bool "Enable accessibility support"
+       help
+         This enables and compiles the accessibility support.
+
 endif # BR2_PACKAGE_QT_GUI_MODULE
 
 choice
index d56fe7e2e83916a234f4b4b3c2c022bb58868bc2..47d5b007f040c5f67373ac557c8bcdc03fcb2abf 100644 (file)
@@ -258,6 +258,12 @@ else
 QT_CONFIGURE_OPTS += -no-libmng
 endif
 
+ifeq ($(BR2_PACKAGE_QT_ACCESSIBILITY),y)
+QT_CONFIGURE_OPTS += -accessibility
+else
+QT_CONFIGURE_OPTS += -no-accessibility
+endif
+
 ifeq ($(BR2_PACKAGE_QT_QTZLIB),y)
 QT_CONFIGURE_OPTS += -qt-zlib
 else
@@ -520,7 +526,6 @@ define QT_CONFIGURE_CMDS
                -no-xinerama \
                -no-cups \
                -no-nis \
-               -no-accessibility \
                -no-separate-debug-info \
                -prefix /usr \
                -plugindir /usr/lib/qt/plugins \