package/openlayers: do not rely on install -D -t
authorThomas Claveirole <thomas.claveirole@green-communications.fr>
Thu, 24 Oct 2019 10:05:58 +0000 (12:05 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 25 Oct 2019 16:24:40 +0000 (18:24 +0200)
Use a more standard $(INSTALL) -D solution instead of -D -t, as it
causes some failures in the autobuilders.

Fixes:

  http://autobuild.buildroot.net/results/b473c44ae953dec3e4f88c4e363fb1a84b5e0dc8/

Signed-off-by: Thomas Claveirole <thomas.claveirole@green-communications.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/openlayers/openlayers.mk

index 6dadc6d96a01b6b7522845fbdf4c3cf73f913995..946f1454e4d83ad19b43fe3b150cf56ed9c81b9a 100644 (file)
@@ -17,8 +17,8 @@ define OPENLAYERS_EXTRACT_CMDS
 endef
 
 define OPENLAYERS_INSTALL_TARGET_CMDS
-       $(INSTALL) -m 0644 -D -t $(TARGET_DIR)/var/www/ \
-               $(@D)/ol.css $(@D)/ol.js
+       $(INSTALL) -D -m 0644 $(@D)/ol.css $(TARGET_DIR)/var/www/ol.css
+       $(INSTALL) -D -m 0644 $(@D)/ol.js $(TARGET_DIR)/var/www/ol.js
 endef
 
 $(eval $(generic-package))