Revert "package/binutils: install libiberty for host build"
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 18 Mar 2019 21:10:22 +0000 (22:10 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 18 Mar 2019 21:10:22 +0000 (22:10 +0100)
This reverts commit 7ec7ba54055919d89afc93606794d161505fa2d8, as it
causes build failures of host-gdb:

/usr/bin/ld: /home/buildroot/autobuild/instance-0/output/host/lib/libiberty.a(cplus-dem.o): relocation R_X86_64_PC32 against symbol `_sch_istable' can not be used when making a shared object; recompile with -fPIC
/usr/bin/ld: final link failed: Bad value

Indeed, the host-gdb build picks up the libiberty installed in
$(HOST_DIR) instead of using its own internal version. This needs to
be addressed before we can make host-binutils install libiberty in
$(HOST_DIR).

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/binutils/binutils.mk

index cfaf0bdeb73329a0022621a597550a8bb33af111..6798356ff2f2fa56e44b05801adab29941882b59 100644 (file)
@@ -84,7 +84,6 @@ HOST_BINUTILS_CONF_OPTS = \
        --target=$(GNU_TARGET_NAME) \
        --disable-shared \
        --enable-static \
-       --enable-install-libiberty \
        --with-sysroot=$(STAGING_DIR) \
        --enable-poison-system-directories \
        $(BINUTILS_DISABLE_GDB_CONF_OPTS) \