package: remove references to uClibc 0.9.32
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 1 Jul 2014 18:03:04 +0000 (20:03 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 10 Jul 2014 14:15:59 +0000 (16:15 +0200)
This commit removes all remaining references to uClibc 0.9.32.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/aiccu/Config.in
package/connman/Config.in
package/fio/Config.in
package/iputils/Config.in
package/libglib2/libglib2.mk
package/mpd/Config.in
package/mtr/Config.in

index a6933b661047563041e3ad7704ca01b8f49e79b4..51e5fb76d60b876d4e7dbb210c8b7702b7a5f319 100644 (file)
@@ -5,8 +5,7 @@ config BR2_PACKAGE_AICCU
        depends on BR2_TOOLCHAIN_HAS_THREADS
        depends on BR2_USE_MMU # fork()
        # Uses dn_skipname(), only available since 0.9.33
-       depends on !BR2_UCLIBC_VERSION_0_9_31 && \
-               !BR2_UCLIBC_VERSION_0_9_32
+       depends on !BR2_UCLIBC_VERSION_0_9_31
        # AVR32 only has uClibc 0.9.31, so there's no way it can build
        # due to the lack of dn_skipname(), even with external
        # toolchains.
index 7160905a9425cc8c0678a018bf4cc2219638b119..a42de1719027a00f766c37b69c222834ba76ee1d 100644 (file)
@@ -4,7 +4,6 @@ config BR2_PACKAGE_CONNMAN
        select BR2_PACKAGE_LIBGLIB2
        select BR2_PACKAGE_IPTABLES
        depends on !BR2_avr32 # no inotify_init1
-       depends on !BR2_UCLIBC_VERSION_0_9_32
        depends on BR2_USE_WCHAR # libglib2
        depends on BR2_INET_IPV6
        depends on BR2_TOOLCHAIN_HAS_THREADS # dbus, libglib2
@@ -67,5 +66,4 @@ endif # BR2_PACKAGE_CONNMAN
 
 comment "connman needs a toolchain w/ IPv6, wchar, threads, resolver"
        depends on BR2_USE_MMU && !BR2_avr32
-       depends on BR2_UCLIBC_VERSION_0_9_32 || \
-               !BR2_USE_WCHAR || !BR2_INET_IPV6 || !BR2_TOOLCHAIN_HAS_THREADS
+       depends on !BR2_USE_WCHAR || !BR2_INET_IPV6 || !BR2_TOOLCHAIN_HAS_THREADS
index 3f0599d7d597f106a564278e49919347ef4ca7b1..6c1b6cbfa3d22312f5405d6cc79601614c624e0c 100644 (file)
@@ -7,11 +7,10 @@ config BR2_PACKAGE_FIO
        # release of uClibc, but is part of uClibc Git, and backported
        # in Buildroot patch set of uClibc 0.9.33. Therefore, we
        # disable the build of fio for external uClibc toolchains
-       # (which use an unknown uClibc version) and for 0.9.31 and
-       # 0.9.32 which don't have posix_madvise().
+       # (which use an unknown uClibc version) and for 0.9.31 which
+       # don't have posix_madvise().
        depends on !BR2_TOOLCHAIN_EXTERNAL_UCLIBC && \
-               !BR2_UCLIBC_VERSION_0_9_31 && \
-               !BR2_UCLIBC_VERSION_0_9_32
+               !BR2_UCLIBC_VERSION_0_9_31
        # fio uses fallocate() which becomes fallocate64() while compiling
        # with BR2_LARGEFILE but fallocate64() is not available on nios2
        depends on !BR2_nios2
index e7bb3d967747d4b4514003cea994dff53bd425f0..456fddf769216f6ba353737fefe98fa30d5a2a9e 100644 (file)
@@ -4,8 +4,7 @@ config BR2_PACKAGE_IPUTILS
        depends on BR2_USE_MMU # fork()
        # requires dn_comp (only available in since uclibc 0.9.33)
        depends on !BR2_avr32
-       depends on !BR2_UCLIBC_VERSION_0_9_31 && \
-               !BR2_UCLIBC_VERSION_0_9_32
+       depends on !BR2_UCLIBC_VERSION_0_9_31
        help
          This package is set of small useful utilities for Linux networking.
          It includes complete versions of ping, traceroute, etc.
index 8df7c55df6f9ef36e5eb82f4fad02fd43fb9399e..122c6c9c741e2808050c8a280aea7f0845959f6c 100644 (file)
@@ -50,7 +50,7 @@ LIBGLIB2_CONF_ENV = \
                gt_cv_c_wchar_t=$(if $(BR2_USE_WCHAR),yes,no)
 
 # old uClibc versions don't provide qsort_r
-ifeq ($(BR2_UCLIBC_VERSION_0_9_31)$(BR2_UCLIBC_VERSION_0_9_32)$(BR2_TOOLCHAIN_EXTERNAL_UCLIBC)$(BR2_TOOLCHAIN_EXTERNAL_XILINX_MICROBLAZEEL_V2)$(BR2_TOOLCHAIN_EXTERNAL_XILINX_MICROBLAZEBE_V2),y)
+ifeq ($(BR2_UCLIBC_VERSION_0_9_31)$(BR2_TOOLCHAIN_EXTERNAL_UCLIBC)$(BR2_TOOLCHAIN_EXTERNAL_XILINX_MICROBLAZEEL_V2)$(BR2_TOOLCHAIN_EXTERNAL_XILINX_MICROBLAZEBE_V2),y)
 LIBGLIB2_CONF_ENV += glib_cv_have_qsort_r=no
 else
 LIBGLIB2_CONF_ENV += glib_cv_have_qsort_r=yes
index b49112636205652d4900f478b86f20787e3beea7..e09be0bae9e4932ebfbb8638f8e64efd6cc6c0ff 100644 (file)
@@ -7,7 +7,6 @@ menuconfig BR2_PACKAGE_MPD
        # avr32, sparc & CS powerpc gcc are too old
        depends on !(BR2_avr32 || BR2_sparc)
        depends on !(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_POWERPC201103 || BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_POWERPC201009)
-       depends on !BR2_UCLIBC_VERSION_0_9_32 # lacks signalfd
        select BR2_PACKAGE_LIBGLIB2
        select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
        select BR2_PACKAGE_MPD_TREMOR if !(BR2_PACKAGE_MPD_MAD || BR2_PACKAGE_MPD_MPG123 || BR2_PACKAGE_MPD_VORBIS || BR2_PACKAGE_MPD_WAVPACK || BR2_PACKAGE_MPD_FLAC || BR2_PACKAGE_MPD_MUSEPACK || BR2_PACKAGE_MPD_FFMPEG)
index 7e5ad90cd09b7905cf3c408aa84b4bbeafe916e4..4e529d6bf36e58055fa204dcf208aadf0589eaa8 100644 (file)
@@ -1,7 +1,7 @@
 config BR2_PACKAGE_MTR
        bool "mtr"
        # res_mkquery() only available in 0.9.33+
-       depends on !BR2_UCLIBC_VERSION_0_9_31 && !BR2_UCLIBC_VERSION_0_9_32
+       depends on !BR2_UCLIBC_VERSION_0_9_31
        depends on !BR2_avr32
        help
          mtr combines the functionality of the 'traceroute' and 'ping'