package/rpm: drop binutils optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 31 Mar 2019 14:49:34 +0000 (16:49 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 31 Mar 2019 19:13:20 +0000 (21:13 +0200)
Since bump to version 4.14.2.1, binutils is not an optional dependency
anymore as bfd.h has been droped in 4.14.0 with
https://github.com/rpm-software-management/rpm/commit/245b5a3b4b6d616adf47361137987e90f8dab22c

So drop it and manage optional elfutils dependency through a
single line (and drop binutils/elfutils comment)

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/rpm/rpm.mk

index 5fd725661854396ed2e8b5b3692b702da83f9611..75a03abf4d20e7ec8e1875269f1278db6abeb3f0 100644 (file)
@@ -12,6 +12,7 @@ RPM_DEPENDENCIES = \
        host-pkgconf \
        berkeleydb \
        $(if $(BR2_PACKAGE_BZIP2),bzip2) \
+       $(if $(BR2_PACKAGE_ELFUTILS),elfutils) \
        file \
        popt \
        $(if $(BR2_PACKAGE_XZ),xz) \
@@ -82,16 +83,6 @@ else
 RPM_CONF_OPTS += --without-selinux
 endif
 
-# For the elfutils and binutils dependencies, there are no
-# configuration options to explicitly enable/disable them.
-ifeq ($(BR2_PACKAGE_ELFUTILS),y)
-RPM_DEPENDENCIES += elfutils
-endif
-
-ifeq ($(BR2_PACKAGE_BINUTILS),y)
-RPM_DEPENDENCIES += binutils
-endif
-
 ifeq ($(BR2_PACKAGE_ZSTD),y)
 RPM_DEPENDENCIES += zstd
 RPM_CONF_OPTS += --enable-zstd