subversion: new package
authorRico Bachmann <bachmann@tofwerk.com>
Tue, 27 Aug 2013 17:08:05 +0000 (19:08 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 27 Aug 2013 22:25:59 +0000 (00:25 +0200)
[Thomas: added license informations, fixed dependencies, and several
cleanups.]

Signed-off-by: Rico Bachmann <bachmann@tofwerk.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/subversion/Config.in [new file with mode: 0644]
package/subversion/subversion.mk [new file with mode: 0644]

index f7b0360b88422d47ad9b4c46974ec5c141720cc0..53e401ba3c28070081f95d4329b1d2148d70cbe3 100644 (file)
@@ -97,6 +97,7 @@ if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 source "package/sed/Config.in"
 endif
 source "package/sstrip/Config.in"
+source "package/subversion/Config.in"
 if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 source "package/tar/Config.in"
 endif
diff --git a/package/subversion/Config.in b/package/subversion/Config.in
new file mode 100644 (file)
index 0000000..c1358fe
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_SUBVERSION
+       bool "subversion"
+       select BR2_PACKAGE_APR_UTIL
+       # apr really needs shared library support
+       depends on !BR2_PREFER_STATIC_LIB
+       select BR2_PACKAGE_NEON
+       select BR2_PACKAGE_NEON_XML
+       help
+         Subversion is an open source version control system
+
+         http://subversion.apache.org/
diff --git a/package/subversion/subversion.mk b/package/subversion/subversion.mk
new file mode 100644 (file)
index 0000000..de4db7c
--- /dev/null
@@ -0,0 +1,28 @@
+################################################################################
+#
+# subversion
+#
+################################################################################
+
+SUBVERSION_VERSION = 1.7.9
+SUBVERSION_SITE = http://archive.apache.org/dist/subversion
+SUBVERSION_LICENSE = Apache 2.0
+SUBVERSION_LICENSE_FILES = LICENSE
+
+SUBVERSION_DEPENDENCIES = apr apr-util expat neon zlib
+SUBVERSION_CONF_OPT = \
+       --with-expat=$(STAGING_DIR)/usr/include:$(STAGING_DIR)/usr/lib: \
+       --with-apr=$(STAGING_DIR)/usr \
+       --with-apr-util=$(STAGING_DIR)/usr \
+       --with-zlib=$(STAGING_DIR)/usr \
+       --with-neon=$(STAGING_DIR)/usr \
+       --without-gssapi \
+       --without-serf \
+       --without-apxs \
+       --without-berkeyley-db \
+       --without-sasl \
+       --without-gnome-keyring \
+       --without-ssl \
+       --without-libmagic
+
+$(eval $(autotools-package))