libevent: supports only the real OpenSSL, not LibreSSL
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 21 Oct 2017 17:02:11 +0000 (19:02 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 21 Oct 2017 19:28:13 +0000 (21:28 +0200)
libevent will not build with LibreSSL without patches, so let's
support only OpenSSL.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libevent/libevent.mk

index 36bca0b21b82fc0f32375c20c3675ddf81c76bb4..fc4108f6fd081df89a1edfaf25f1f3e40bbdb986 100644 (file)
@@ -23,8 +23,8 @@ ifneq ($(BR2_PACKAGE_PYTHON),y)
 LIBEVENT_POST_INSTALL_TARGET_HOOKS += LIBEVENT_REMOVE_PYSCRIPT
 endif
 
-ifeq ($(BR2_PACKAGE_OPENSSL),y)
-LIBEVENT_DEPENDENCIES += host-pkgconf openssl
+ifeq ($(BR2_PACKAGE_LIBOPENSSL),y)
+LIBEVENT_DEPENDENCIES += host-pkgconf libopenssl
 LIBEVENT_CONF_OPTS += --enable-openssl
 else
 LIBEVENT_CONF_OPTS += --disable-openssl