package/tzdate: use classic 'fat' format for uClibc/glibc compatibility
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 15 Feb 2021 18:57:09 +0000 (19:57 +0100)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 16 Feb 2021 20:23:38 +0000 (21:23 +0100)
Fixes:
https://gitlab.com/buildroot.org/buildroot/-/jobs/1019385940

FAIL: test_run (tests.core.test_timezone.TestGlibcNonDefaultLimitedTimezone)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builds/buildroot.org/buildroot/support/testing/tests/core/test_timezone.py", line 66, in test_run
    self.assertEqual(tz[0].strip(), "EST")
AssertionError: '' != 'EST'

Commit 7868289fd5348 (package/zic: bump version to 2020f) bumped the zic
version to 2020f, which changed the default output format from the classic
"fat" format to the new "slim" format:

https://github.com/eggert/tz/commit/6ba6f2117b95eab345a7ed9159cef939e30c4cd3

The slim format is unfortunately not supported by glibc < 2.28 or uClibc, so
explicitly request the classic "fat" format.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/tzdata/tzdata.mk

index 04f5d84bf061b9275679412ce6b21e3a983cc2a6..8201dc1201db5d9fc3efb37c333cb5e670426c36 100644 (file)
@@ -51,8 +51,8 @@ endef
 define HOST_TZDATA_BUILD_CMDS
        (cd $(@D); \
                for zone in $(TZDATA_ZONELIST); do \
-                       $(ZIC) -d _output/posix $$zone || exit 1; \
-                       $(ZIC) -d _output/right -L leapseconds $$zone || exit 1; \
+                       $(ZIC) -b fat -d _output/posix $$zone || exit 1; \
+                       $(ZIC) -b fat -d _output/right -L leapseconds $$zone || exit 1; \
                done; \
        )
 endef