- store uClibc's configfile as BR2_UCLIBC_CONFIG in menuconfig
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Sat, 12 May 2007 18:39:28 +0000 (18:39 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Sat, 12 May 2007 18:39:28 +0000 (18:39 -0000)
toolchain/uClibc/Config.in
toolchain/uClibc/uclibc.mk

index 9005bdaeaaf494b4b5d5fff94e0b9adb5e3cbd36..7e228478dc617b5d985ce92b6cf095fadd72d2f0 100644 (file)
@@ -14,8 +14,12 @@ choice
                bool "uClibc 0.9.28"
 
        config BR2_UCLIBC_VERSION_0_9_28_3
+               depends BR2_DEPRECATED
                bool "uClibc 0.9.28.3"
 
+       config BR2_UCLIBC_VERSION_0_9_29
+               bool "uClibc 0.9.29"
+
        config BR2_UCLIBC_VERSION_SNAPSHOT
                bool "daily snapshot"
 
@@ -29,6 +33,19 @@ config BR2_USE_UCLIBC_SNAPSHOT
        help
            Use latest snapshot or one from a specific date?
 
+config BR2_UCLIBC_CONFIG
+       string "uClibc configuration file to use?"
+       default "toolchain/uClibc/uClibc-0.9.28.config" if BR2_UCLIBC_VERSION_0_9_28
+       default "toolchain/uClibc/uClibc-0.9.28.config" if BR2_UCLIBC_VERSION_0_9_28_3
+       default "toolchain/uClibc/uClibc-0.9.29.config" if BR2_UCLIBC_VERSION_0_9_29
+       default "toolchain/uClibc/uClibc-0.9.29.config" if BR2_UCLIBC_VERSION_0_9_30
+       default "toolchain/uClibc/uClibc-0.9.29.config" if BR2_UCLIBC_VERSION_SNAPSHOT
+       help
+         Some people may wish to use their own modified uClibc configuration
+         file and will specify their config file location with this option.
+         See also docs/README in this package.
+         If unsure, use the default.
+
 config BR2_ENABLE_LOCALE
        bool "Enable locale/gettext/i18n support?"
        default n
index 91dece7b9a2cba7661902842a5d9358e8686d660..09c29134fb95e078022c38601a0c04dde6c31c51 100644 (file)
@@ -6,6 +6,13 @@
 
 ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
 
+# specifying UCLIBC_CONFIG_FILE on the command-line overrides the .config
+# setting.
+ifndef UCLIBC_CONFIG_FILE
+UCLIBC_CONFIG_FILE=$(subst ",, $(strip $(BR2_UCLIBC_CONFIG)))
+#")
+endif
+
 ifeq ($(BR2_UCLIBC_VERSION_SNAPSHOT),y)
 # Be aware that this changes daily....
 UCLIBC_VER:=0.9.29
@@ -13,22 +20,21 @@ UCLIBC_DIR:=$(TOOL_BUILD_DIR)/uClibc
 UCLIBC_SOURCE:=uClibc-$(strip $(subst ",, $(BR2_USE_UCLIBC_SNAPSHOT))).tar.bz2
 #"))
 UCLIBC_SITE:=http://www.uclibc.org/downloads/snapshots
-ifndef UCLIBC_CONFIG_FILE
-UCLIBC_CONFIG_FILE=toolchain/uClibc/uClibc-0.9.29.config
-endif
 else
+# releases
+ifeq ($(BR2_UCLIBC_VERSION_0_9_29),y)
+UCLIBC_VER:=0.9.29
+endif
 ifeq ($(BR2_UCLIBC_VERSION_0_9_28_3),y)
 UCLIBC_VER:=0.9.28.3
 endif
 ifeq ($(BR2_UCLIBC_VERSION_0_9_28),y)
 UCLIBC_VER:=0.9.28
 endif
+
 UCLIBC_DIR:=$(TOOL_BUILD_DIR)/uClibc-$(UCLIBC_VER)
 UCLIBC_SOURCE:=uClibc-$(UCLIBC_VER).tar.bz2
 UCLIBC_SITE:=http://www.uclibc.org/downloads
-ifndef UCLIBC_CONFIG_FILE
-UCLIBC_CONFIG_FILE=toolchain/uClibc/uClibc-0.9.28.config
-endif
 endif
 
 UCLIBC_CAT:=$(BZCAT)