fix building of procps on mips systems
authorMike Frysinger <vapier@gentoo.org>
Thu, 14 Oct 2004 18:17:33 +0000 (18:17 -0000)
committerMike Frysinger <vapier@gentoo.org>
Thu, 14 Oct 2004 18:17:33 +0000 (18:17 -0000)
package/procps/procps-mips-define-pagesize.patch [new file with mode: 0644]
package/procps/procps.mk

diff --git a/package/procps/procps-mips-define-pagesize.patch b/package/procps/procps-mips-define-pagesize.patch
new file mode 100644 (file)
index 0000000..3802f4c
--- /dev/null
@@ -0,0 +1,29 @@
+diff -Naurp procps-3.2.3.orig/minimal.c procps-3.2.3/minimal.c
+--- procps-3.2.3.orig/minimal.c        2004-05-04 20:26:14.000000000 -0400
++++ procps-3.2.3/minimal.c     2004-08-20 02:01:35.868100752 -0400
+@@ -68,8 +68,8 @@
+ ///////////////////////////////////////////////////////////
+ #ifndef PAGE_SIZE
+-#warning PAGE_SIZE not defined, assuming it is 4096
+-#define PAGE_SIZE 4096
++#warning PAGE_SIZE not defined, using sysconf() to determine correct value
++#define PAGE_SIZE (sysconf(_SC_PAGESIZE))
+ #endif
+diff -Naurp procps-3.2.3.orig/ps/common.h procps-3.2.3/ps/common.h
+--- procps-3.2.3.orig/ps/common.h      2004-04-25 17:03:18.000000000 -0400
++++ procps-3.2.3/ps/common.h   2004-08-20 02:00:59.228670792 -0400
+@@ -16,6 +16,11 @@
+ #include "../proc/readproc.h"
+ #include <asm/page.h>  /* looks safe for glibc, we need PAGE_SIZE */
++#ifndef PAGE_SIZE
++#warning PAGE_SIZE not defined, using sysconf() to determine correct value
++#define PAGE_SIZE (sysconf(_SC_PAGESIZE))
++#endif
++
+ #if 0
+ #define trace(args...) printf(## args)
+ #else
index abd8bd803e882b2d24fd796f6086247d455468d5..89573a2c2f1c7657f880b00816a612555bf2cd7a 100644 (file)
@@ -15,6 +15,7 @@ $(DL_DIR)/$(PROCPS_SOURCE):
 
 $(PROCPS_DIR)/.source: $(DL_DIR)/$(PROCPS_SOURCE)
        zcat $(DL_DIR)/$(PROCPS_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+       toolchain/patch-kernel.sh $(PROCPS_DIR) package/procps/ procps*.patch
        $(SED) '/^CFLAGS/s:-O2:$(TARGET_CFLAGS):' $(PROCPS_DIR)/Makefile
        touch $(PROCPS_DIR)/.source