dante: add linux-pam optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 22 Nov 2018 17:49:14 +0000 (18:49 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 24 Nov 2018 12:01:34 +0000 (13:01 +0100)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/dante/dante.mk

index a147aa36dc4e8f90725e0307e517a8c3e0e67ed6..9666ec54fde488bc50cea551ec4963d642c0df8e 100644 (file)
@@ -12,7 +12,14 @@ DANTE_LICENSE_FILES = LICENSE
 # Dante uses a *VERY* old configure.ac
 DANTE_LIBTOOL_PATCH = NO
 
-DANTE_CONF_OPTS += --disable-client --disable-preload --without-pam
+DANTE_CONF_OPTS += --disable-client --disable-preload
+
+ifeq ($(BR2_PACKAGE_LINUX_PAM),y)
+DANTE_DEPENDENCIES += linux-pam
+DANTE_CONF_OPTS += --with-pam
+else
+DANTE_CONF_OPTS += --without-pam
+endif
 
 define DANTE_INSTALL_CONFIG_FILE
        $(INSTALL) -D -m 644 $(@D)/example/sockd.conf \