atf: new package
authorSebastien Bourdelin <sebastien.bourdelin@savoirfairelinux.com>
Thu, 11 Jun 2015 22:51:31 +0000 (18:51 -0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 12 Jun 2015 19:34:28 +0000 (21:34 +0200)
ATF, or Automated Testing Framework, is a collection of libraries to
write test programs in C, C++ and POSIX shell.

https://github.com/jmmv/atf

Signed-off-by: Sebastien Bourdelin <sebastien.bourdelin@savoirfairelinux.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/atf/Config.in [new file with mode: 0644]
package/atf/atf.hash [new file with mode: 0644]
package/atf/atf.mk [new file with mode: 0644]

index a17901f6130d2627e0955e1e1227b98e68bae147..d111a82eab056b9d2fa580667f948cad6df80256 100644 (file)
@@ -1005,6 +1005,7 @@ menu "Other"
        source "package/apr-util/Config.in"
        source "package/argp-standalone/Config.in"
        source "package/armadillo/Config.in"
+       source "package/atf/Config.in"
        source "package/bdwgc/Config.in"
        source "package/boost/Config.in"
        source "package/clapack/Config.in"
diff --git a/package/atf/Config.in b/package/atf/Config.in
new file mode 100644 (file)
index 0000000..59712ab
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_ATF
+       bool "atf"
+       depends on BR2_INSTALL_LIBSTDCPP
+       help
+         ATF, or Automated Testing Framework, is a collection of
+         libraries to write test programs in C, C++ and POSIX shell.
+
+         https://github.com/jmmv/atf
+
+comment "atf needs a toolchain w/ C++"
+       depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/atf/atf.hash b/package/atf/atf.hash
new file mode 100644 (file)
index 0000000..78cd3c6
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally computed
+sha256 92bc64180135eea8fe84c91c9f894e678767764f6dbc8482021d4dde09857505 atf-0.21.tar.gz
diff --git a/package/atf/atf.mk b/package/atf/atf.mk
new file mode 100644 (file)
index 0000000..ed2080e
--- /dev/null
@@ -0,0 +1,24 @@
+################################################################################
+#
+# atf
+#
+################################################################################
+
+ATF_VERSION = 0.21
+ATF_SITE = https://github.com/jmmv/atf/releases/download/atf-$(ATF_VERSION)
+ATF_INSTALL_STAGING = YES
+ATF_LICENSE = BSD-2c, BSD-3c
+ATF_LICENSE_FILES = COPYING
+# Ships a beta libtool version hence our patch doesn't apply.
+ATF_AUTORECONF = YES
+# Do not install precompiled tests.
+ATF_INSTALL_TARGET_OPTS = DESTDIR=$(TARGET_DIR) install-exec
+
+# ATF_SHELL defaults to the host's bash
+ATF_CONF_ENV = \
+       kyua_cv_getopt_plus=yes \
+       kyua_cv_attribute_noreturn=yes \
+       kyua_cv_getcwd_works=yes \
+       ATF_SHELL=/bin/sh
+
+$(eval $(autotools-package))