atftp: new package
authorRyan Barnett <ryan.barnett@rockwellcollins.com>
Mon, 23 Jun 2014 14:47:48 +0000 (09:47 -0500)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 24 Jun 2014 14:18:35 +0000 (16:18 +0200)
[Peter: note that readline is optional, drop trailing Config.in line]
Signed-off-by: Ryan Barnett <ryan.barnett@rockwellcollins.com>
CC: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/atftp/0001-Makefile.am-link-against-libpthread-for-atftp.patch [new file with mode: 0644]
package/atftp/Config.in [new file with mode: 0644]
package/atftp/atftp.mk [new file with mode: 0644]

index 498630f6f6b05081d118b547b275c9f055c0f45d..c46c0ec4721b1b03428495e1bd351a1bea9448a1 100644 (file)
@@ -897,6 +897,7 @@ menu "Networking applications"
        source "package/aircrack-ng/Config.in"
        source "package/argus/Config.in"
        source "package/arptables/Config.in"
+       source "package/atftp/Config.in"
        source "package/autossh/Config.in"
        source "package/avahi/Config.in"
        source "package/axel/Config.in"
diff --git a/package/atftp/0001-Makefile.am-link-against-libpthread-for-atftp.patch b/package/atftp/0001-Makefile.am-link-against-libpthread-for-atftp.patch
new file mode 100644 (file)
index 0000000..e879df5
--- /dev/null
@@ -0,0 +1,26 @@
+Makefile.am: link against libpthread for atftp
+
+atftp client needs to link against libpthread as static builds do not
+work otherwise.
+
+Signed-off-by: Ryan Barnett <ryan.barnett@rockwellcollins.com>
+---
+ Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index e59592f..200829a 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -28,7 +28,7 @@ noinst_HEADERS   = argz.h logger.h options.h stats.h tftp.h tftp_def.h tftp_io.h
+                  tftpd.h tftpd_pcre.h tftpd_mtftp.h
+ bin_PROGRAMS     = atftp
+-atftp_LDADD      = $(LIBTERMCAP) $(LIBREADLINE)
++atftp_LDADD      = $(LIBTERMCAP) $(LIBREADLINE) $(LIBPTHREAD)
+ atftp_SOURCES    = tftp.c tftp_io.c logger.c options.c tftp_def.c tftp_file.c \
+                  argz.c tftp_mtftp.c
+-- 
+1.9.1
+
diff --git a/package/atftp/Config.in b/package/atftp/Config.in
new file mode 100644 (file)
index 0000000..2a3df76
--- /dev/null
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_ATFTP
+       bool "atftp"
+       depends on BR2_INET_IPV6
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       help
+         atftp is a client/server implementation of the TFTP
+         protocol that implements RFCs 1350, 2090, 2347, 2348,
+         and 2349. The server is multi-threaded and the client
+         presents a friendly interface using libreadline
+         (if enabled).
+
+         http://sourceforge.net/projects/atftp/
+
+comment "atftp needs a toolchain w/ threads, IPv6"
+       depends on !BR2_TOOLCHAIN_HAS_THREADS || !BR2_INET_IPV6
diff --git a/package/atftp/atftp.mk b/package/atftp/atftp.mk
new file mode 100644 (file)
index 0000000..1d6a7c3
--- /dev/null
@@ -0,0 +1,27 @@
+################################################################################
+#
+# atftp
+#
+################################################################################
+
+ATFTP_VERSION  = 0.7.1
+ATFTP_SITE = http://sourceforge.net/projects/atftp/files/
+ATFTP_LICENSE = GPLv2+
+ATFTP_LICENSE_FILES = LICENSE
+ATFTP_CONF_OPT = --disable-libwrap --disable-mtftp
+
+ifeq ($(BR2_PACKAGE_READLINE),y)
+ATFTP_DEPENDENCIES += readline
+ATFTP_CONF_OPT += --enable-libreadline
+else
+ATFTP_CONF_OPT += --disable-libreadline
+endif
+
+ifeq ($(BR2_PACKAGE_PCRE),y)
+ATFTP_DEPENDENCIES += pcre
+ATFTP_CONF_OPT += --enable-libpcre
+else
+ATFTP_CONF_OPT += --disable-libpcre
+endif
+
+$(eval $(autotools-package))