external toolchain: also copy the libthread_db.so for gdbserver
authorYann E. MORIN <yann.morin.1998@anciens.enib.fr>
Fri, 28 May 2010 21:23:20 +0000 (23:23 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 28 May 2010 21:31:39 +0000 (23:31 +0200)
gdbserver dlopen(3)s libthread_db.so at runtime, so there is no
dependency on it (does not appear as being (NEEDED)).

Copy libthread_db.so from external toolchain when gdbserver is enbled.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/external-toolchain/ext-tool.mk

index e858edb8c2f50393c66f02cb398156091dd3ec11..8daae15aecc13d4ada190ce77bb9a0fca8c9b34c 100644 (file)
@@ -264,6 +264,9 @@ endif
 
 ifneq ($(BR2_PTHREADS_NONE),y)
 EXTERNAL_LIBS+=libpthread.so
+ifeq ($(BR2_PACKAGE_GDB_SERVER),y)
+EXTERNAL_LIBS+=libthread_db.so
+endif # gdbserver
 endif # ! no threads
 
 # SYSROOT_DIR selection. We first try the -print-sysroot option,