package/nginx: add http geoip support
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 21 Jun 2020 17:12:22 +0000 (19:12 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 21 Jun 2020 20:51:31 +0000 (22:51 +0200)
http geoip module is available since version 0.8.6 and
https://github.com/nginx/nginx/commit/bc10147b9f36f1a61b96ceec016bf4d4d12e128f

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/nginx/Config.in
package/nginx/nginx.mk

index 5c34f11edde3f56b28e62ddcea8b43d722747822..0dbeaae2ffbb03565dbb8c43bf5828d5c76b070a 100644 (file)
@@ -75,6 +75,12 @@ config BR2_PACKAGE_NGINX_HTTP_IMAGE_FILTER_MODULE
        help
          Enable ngx_http_image_filter_module
 
+config BR2_PACKAGE_NGINX_HTTP_GEOIP_MODULE
+       bool "ngx_http_geoip_module"
+       select BR2_PACKAGE_GEOIP
+       help
+         Enable ngx_http_geoip_module
+
 config BR2_PACKAGE_NGINX_HTTP_SUB_MODULE
        bool "ngx_http_sub_module"
        help
index 0ceed7857f7823400708c115cb9492e6bf077f5c..3f249096bc901edee8c9246fa39dd32a4b471a16 100644 (file)
@@ -85,7 +85,6 @@ endif
 
 # modules disabled or not activated because of missing dependencies:
 # - google_perftools  (googleperftools)
-# - http_geoip_module (geoip)
 # - http_perl_module  (host-perl)
 # - pcre-jit          (want to rebuild pcre)
 
@@ -134,6 +133,11 @@ NGINX_DEPENDENCIES += gd jpeg libpng
 NGINX_CONF_OPTS += --with-http_image_filter_module
 endif
 
+ifeq ($(BR2_PACKAGE_NGINX_HTTP_GEOIP_MODULE),y)
+NGINX_DEPENDENCIES += geoip
+NGINX_CONF_OPTS += --with-http_geoip_module
+endif
+
 ifeq ($(BR2_PACKAGE_NGINX_HTTP_GUNZIP_MODULE),y)
 NGINX_DEPENDENCIES += zlib
 NGINX_CONF_OPTS += --with-http_gunzip_module