gvfs: enable admin backend
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 19 Oct 2018 20:13:12 +0000 (22:13 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 20 Oct 2018 16:03:50 +0000 (18:03 +0200)
Enable admin backend if libcap and polkit are available

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gvfs/gvfs.mk

index 82683d7da17d171b876ff811225b7c2ed23a1e82..4ad66b8a6a7a749115daec6d0c12fc4daff1962a 100644 (file)
@@ -20,7 +20,6 @@ GVFS_CONF_ENV = ac_cv_path_LIBGCRYPT_CONFIG=$(STAGING_DIR)/usr/bin/libgcrypt-con
 # Most of these are missing library support
 GVFS_CONF_OPTS = \
        --disable-afc \
-       --disable-admin \
        --disable-cdda \
        --disable-gcr \
        --disable-gdu \
@@ -66,6 +65,13 @@ else
 GVFS_CONF_OPTS += --disable-bluray
 endif
 
+ifeq ($(BR2_PACKAGE_LIBCAP)$(BR2_PACKAGE_POLKIT),yy)
+GVFS_DEPENDENCIES += libcap polkit
+GVFS_CONF_OPTS += --enable-admin
+else
+GVFS_CONF_OPTS += --disable-admin
+endif
+
 ifeq ($(BR2_PACKAGE_LIBFUSE),y)
 GVFS_DEPENDENCIES += libfuse
 GVFS_CONF_OPTS += --enable-fuse