e2fsprogs: fix missing fallocate64() on nios2
authorFrank Bergmann <frank@frajasalo.de>
Thu, 20 Feb 2014 21:59:37 +0000 (22:59 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 27 Feb 2014 13:20:42 +0000 (14:20 +0100)
(external) nios2 toolchain is currently missing the fallocate64 system
call. Because of compiling the e2fsprogs package with _FILE_OFFSET_BITS=64,
_LARGEFILE_SOURCE and _LARGEFILE64_SOURCE the fallocate call is replaced
by fallocate64 by the glibc. Therefore fallocate is entirely disabled while
configuring the package.

Fixes http://autobuild.buildroot.org/results/70a/70a47bd7392560cbc1c64769c8357c0b4c91ca3b/

Signed-off-by: Frank Bergmann <frank@frajasalo.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/e2fsprogs/e2fsprogs.mk

index 2eb59f56eaf277ea95e3faf68a8e66b018443dcb..76e2d4ec54569b6cfb454dbaf8bbb14ba44a6d33 100644 (file)
@@ -25,6 +25,10 @@ E2FSPROGS_CONF_OPT = \
        --disable-e2initrd-helper \
        --disable-testio-debug
 
+ifeq ($(BR2_nios2),y)
+E2FSPROGS_CONF_ENV += ac_cv_func_fallocate=no
+endif
+
 E2FSPROGS_DEPENDENCIES = host-pkgconf util-linux
 
 E2FSPROGS_MAKE_OPT = \