libmbim: add new package
authorYegor Yefremov <yegorslists@googlemail.com>
Wed, 4 Dec 2013 09:55:03 +0000 (10:55 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 6 Dec 2013 09:29:49 +0000 (10:29 +0100)
[Peter: fixup license info as pointed out by Thomas]
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/libmbim/Config.in [new file with mode: 0644]
package/libmbim/libmbim.mk [new file with mode: 0644]

index 754e38f33f28327417abaa241fee2bb5a336d8d9..5128b34eb14cda8401ddfa76cc24dcbdc988e0d2 100644 (file)
@@ -542,6 +542,7 @@ source "package/libfreefare/Config.in"
 source "package/libftdi/Config.in"
 source "package/libhid/Config.in"
 source "package/libiqrf/Config.in"
+source "package/libmbim/Config.in"
 source "package/libnfc/Config.in"
 source "package/libnfc-llcp/Config.in"
 source "package/libqmi/Config.in"
diff --git a/package/libmbim/Config.in b/package/libmbim/Config.in
new file mode 100644 (file)
index 0000000..ccc0f25
--- /dev/null
@@ -0,0 +1,17 @@
+config BR2_PACKAGE_LIBMBIM
+       bool "libmbim"
+       depends on BR2_USE_WCHAR # libglib2
+       depends on BR2_TOOLCHAIN_HAS_THREADS # libglib2
+       depends on BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_UDEV
+       select BR2_PACKAGE_LIBGLIB2
+       select BR2_PACKAGE_UDEV_ALL_EXTRAS
+       help
+         libmbim is a glib-based library for talking to WWAN modems and
+         devices which speak the Mobile Interface Broadband Model (MBIM)
+         protocol.
+
+         http://www.freedesktop.org/wiki/Software/libmbim/
+
+comment "libmbim needs udev and a toolchain w/ wchar, threads"
+       depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS || \
+               !BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_UDEV
diff --git a/package/libmbim/libmbim.mk b/package/libmbim/libmbim.mk
new file mode 100644 (file)
index 0000000..e10d60f
--- /dev/null
@@ -0,0 +1,19 @@
+################################################################################
+#
+# libmbim
+#
+################################################################################
+
+LIBMBIM_VERSION = 1.4.0
+LIBMBIM_SITE    = http://www.freedesktop.org/software/libmbim/
+LIBMBIM_SOURCE  = libmbim-$(LIBMBIM_VERSION).tar.xz
+LIBMBIM_LICENSE = LGPLv2+ (library), GPLv2+ (programs)
+LIBMBIM_LICENSE_FILES = COPYING
+LIBMBIM_INSTALL_STAGING = YES
+
+LIBMBIM_DEPENDENCIES = libglib2 udev
+
+# we don't want -Werror
+LIBMBIM_CONF_OPT = --enable-more-warnings=no
+
+$(eval $(autotools-package))