package/libvips: add orc optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 4 Apr 2021 14:30:45 +0000 (16:30 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 4 Apr 2021 14:44:35 +0000 (16:44 +0200)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libvips/libvips.mk

index 7e8b705dd2109c917fb2f43b5c226cf8e858d2b2..304861ab83e1973d9c8c77c6b7cbab18c28dd2a4 100644 (file)
@@ -23,7 +23,6 @@ LIBVIPS_CONF_ENV += CXXFLAGS="$(TARGET_CXXFLAGS) $(LIBVIPS_CXXFLAGS)" \
 LIBVIPS_CONF_OPTS = \
        --without-dmalloc \
        --without-gsf \
-       --without-orc \
        --without-lcms \
        --without-OpenEXR \
        --without-openslide \
@@ -86,6 +85,13 @@ else
 LIBVIPS_CONF_OPTS += --without-rsvg
 endif
 
+ifeq ($(BR2_PACKAGE_ORC),y)
+LIBVIPS_CONF_OPTS += --with-orc
+LIBVIPS_DEPENDENCIES += orc
+else
+LIBVIPS_CONF_OPTS += --without-orc
+endif
+
 ifeq ($(BR2_PACKAGE_POPPLER),y)
 LIBVIPS_CONF_OPTS += --with-poppler
 LIBVIPS_DEPENDENCIES += poppler