toolchain/gcc: remove dead code related to host binary stripping
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 30 Jun 2013 19:28:54 +0000 (21:28 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 3 Jul 2013 06:28:15 +0000 (08:28 +0200)
The GCC_STRIP_HOST_BINARIES variable was always defined to 'nope',
which means that the host binaries were never stripped. Get rid of the
corresponding code, which is not in use.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/gcc/gcc-uclibc-4.x.mk

index 92361e56eb7540f3c57d046b0ba14e208a2e91c6..79a01250eb87593f659a8f96f018547483ccacae 100644 (file)
@@ -43,7 +43,6 @@ GCC_SOURCE:=gcc-$(GCC_VERSION).tar.bz2
 GCC_PATCH_DIR:=toolchain/gcc/$(GCC_VERSION)
 GCC_DIR:=$(TOOLCHAIN_DIR)/gcc-$(GCC_VERSION)
 GCC_CAT:=$(BZCAT)
-GCC_STRIP_HOST_BINARIES:=nope
 GCC_SRC_DIR:=$(GCC_DIR)
 
 # Branding works on >= 4.3
@@ -472,10 +471,6 @@ $(GCC_BUILD_DIR3)/.installed: $(GCC_BUILD_DIR3)/.compiled
                rmdir "$(STAGING_DIR)/lib64"; \
                rm "$(STAGING_DIR)/usr/$(GNU_TARGET_NAME)/lib64";\
        fi
-       # Strip the host binaries
-ifeq ($(GCC_STRIP_HOST_BINARIES),true)
-       strip --strip-all -R .note -R .comment $(filter-out %-gccbug %-embedspu,$(wildcard $(HOST_DIR)/usr/bin/$(GNU_TARGET_NAME)-*))
-endif
        # Make sure we have 'cc'.
        if [ ! -e $(HOST_DIR)/usr/bin/$(GNU_TARGET_NAME)-cc ]; then \
                ln -snf $(GNU_TARGET_NAME)-gcc \