xinetd: follow the convention for patch location
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 20 Mar 2013 21:16:17 +0000 (22:16 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 20 Mar 2013 22:28:27 +0000 (23:28 +0100)
Following 5538e4766201aa0 ("rework patch model"), the xinetd patches
were no longer being applied, because they were stored in
package/xinetd/xinetd-2.3.15/*.patch. This lead to xinetd build
failures such as:
http://autobuild.buildroot.org/results/1a032bca894b76facd9e7f01c3b5d370987d7fc8/build-end.log.

This patch fixes this by changing the location and name of the xinetd
patches to follow the new conventions.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/xinetd/xinetd-001-ar.patch [new file with mode: 0644]
package/xinetd/xinetd-002-destdir.patch [new file with mode: 0644]
package/xinetd/xinetd-003-rpc-fix.patch [new file with mode: 0644]
package/xinetd/xinetd-2.3.15/001-ar.patch [deleted file]
package/xinetd/xinetd-2.3.15/002-destdir.patch [deleted file]
package/xinetd/xinetd-2.3.15/003-rpc_fix.patch [deleted file]

diff --git a/package/xinetd/xinetd-001-ar.patch b/package/xinetd/xinetd-001-ar.patch
new file mode 100644 (file)
index 0000000..566f2f7
--- /dev/null
@@ -0,0 +1,74 @@
+This patch changes all of the hard-coded invocations of "ar" to $(AR), to
+support a cross-compilation toolchain.
+
+The content of this patch was copied from the OpenWrt project:
+https://dev.openwrt.org/browser/packages/net/xinetd/patches/001-ar.patch
+
+Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
+
+--- a/libs/src/misc/Makefile.in
++++ b/libs/src/misc/Makefile.in
+@@ -62,7 +62,7 @@
+ $(LIBNAME): $(OBJECTS)
+-      ar r $@ $?
++      $(AR) r $@ $?
+       $(RANLIB) $@
+ install: $(LIBNAME)
+--- a/libs/src/portable/Makefile.in
++++ b/libs/src/portable/Makefile.in
+@@ -57,7 +57,7 @@
+ $(LIBNAME): $(OBJECTS)
+-      ar r $@ $?
++      $(AR) r $@ $?
+       $(RANLIB) $@
+ install: $(LIBNAME)
+--- a/libs/src/pset/Makefile.in
++++ b/libs/src/pset/Makefile.in
+@@ -53,7 +53,7 @@
+       mv $(LIBNAME) $(LIBDIR)/optimized
+ $(LIBNAME): $(OBJECTS)
+-      ar r $@ $?
++      $(AR) r $@ $?
+       $(RANLIB) $@
+ install: $(LIBNAME)
+--- a/libs/src/sio/Makefile.in
++++ b/libs/src/sio/Makefile.in
+@@ -52,7 +52,7 @@
+       $(INSTALL) $(FMODE) $(LIBNAME) $(LIBDIR)/optimized
+ $(LIBNAME): $(OBJECTS)
+-      ar r $@ $?
++      $(AR) r $@ $?
+       $(RANLIB) $@
+ install: $(LIBNAME)
+--- a/libs/src/str/Makefile.in
++++ b/libs/src/str/Makefile.in
+@@ -63,7 +63,7 @@
+       $(INSTALL) $(FMODE) $(LIBNAME) $(LIBDIR)-O
+ $(LIBNAME): $(OBJECTS)
+-      ar r $@ $?
++      $(AR) r $@ $?
+       $(RANLIB) $@
+ LINT_IGNORE=possible pointer alignment|RCSid unused
+--- a/libs/src/xlog/Makefile.in
++++ b/libs/src/xlog/Makefile.in
+@@ -58,7 +58,7 @@
+       $(INSTALL) $(FMODE) $(LIBNAME) $(LIBDIR)/optimized
+ $(LIBNAME): $(OBJECTS)
+-      ar r $@ $?
++      $(AR) r $@ $?
+       $(RANLIB) $@
+ install: $(LIBNAME)
diff --git a/package/xinetd/xinetd-002-destdir.patch b/package/xinetd/xinetd-002-destdir.patch
new file mode 100644 (file)
index 0000000..7a323eb
--- /dev/null
@@ -0,0 +1,55 @@
+This patch adds $(DESTDIR) to xinetd's installation paths, to support 
+installation to a cross-compiled RFS area.
+
+The content of this patch was inspired by the OpenWrt project:
+https://dev.openwrt.org/browser/packages/net/xinetd/patches/002-destdir.patch
+
+Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
+
+diff -urN xinetd-2.3.15.ORIG/Makefile.in xinetd-2.3.15/Makefile.in
+--- xinetd-2.3.15.ORIG/Makefile.in     2007-09-20 13:01:52.000000000 -0400
++++ xinetd-2.3.15/Makefile.in  2012-06-18 10:20:00.540864388 -0400
+@@ -75,27 +75,27 @@
+ install: build
+       for i in $(DAEMONDIR) $(BINDIR) $(MANDIR)/man5 $(MANDIR)/man8 ; do \
+-         test -d $$i || mkdir -p $$i ; done
+-      $(INSTALL_CMD) -m 755 xinetd/xinetd $(DAEMONDIR)
+-      $(INSTALL_CMD) -m 755 xinetd/itox $(DAEMONDIR)
+-      $(INSTALL_CMD) -m 755 $(SRCDIR)/xinetd/xconv.pl $(DAEMONDIR)
+-      $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.conf.man $(MANDIR)/man5/xinetd.conf.5
+-      $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.log.man $(MANDIR)/man8/xinetd.log.8
+-      $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.man $(MANDIR)/man8/xinetd.8
+-      $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/itox.8 $(MANDIR)/man8/itox.8
+-      $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xconv.pl.8 $(MANDIR)/man8/xconv.pl.8
++         test -d $(DESTDIR)$$i || mkdir -p $(DESTDIR)$$i ; done
++      $(INSTALL_CMD) -m 755 xinetd/xinetd $(DESTDIR)$(DAEMONDIR)
++      $(INSTALL_CMD) -m 755 xinetd/itox $(DESTDIR)$(DAEMONDIR)
++      $(INSTALL_CMD) -m 755 $(SRCDIR)/xinetd/xconv.pl $(DESTDIR)$(DAEMONDIR)
++      $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.conf.man $(DESTDIR)$(MANDIR)/man5/xinetd.conf.5
++      $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.log.man $(DESTDIR)$(MANDIR)/man8/xinetd.log.8
++      $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.man $(DESTDIR)$(MANDIR)/man8/xinetd.8
++      $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/itox.8 $(DESTDIR)$(MANDIR)/man8/itox.8
++      $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xconv.pl.8 $(DESTDIR)$(MANDIR)/man8/xconv.pl.8
+       @echo "You must put your xinetd.conf in /etc/xinetd.conf"
+       @echo "There is a sample config file in xinetd/sample.conf and you can"
+       @echo "use xconv.pl to convert your old inetd.conf file to an xinetd format"
+ uninstall:
+-      rm -f $(DAEMONDIR)/xinetd
+-      rm -f $(DAEMONDIR)/itox
+-      rm -f $(DAEMONDIR)/xconv.pl
+-      rm -f $(MANDIR)/man5/xinetd.conf.5
+-      rm -f $(MANDIR)/man8/xinetd.log.8
+-      rm -f $(MANDIR)/man8/xinetd.8
+-      rm -f $(MANDIR)/man8/itox.8
++      rm -f $(DESTDIR)$(DAEMONDIR)/xinetd
++      rm -f $(DESTDIR)$(DAEMONDIR)/itox
++      rm -f $(DESTDIR)$(DAEMONDIR)/xconv.pl
++      rm -f $(DESTDIR)$(MANDIR)/man5/xinetd.conf.5
++      rm -f $(DESTDIR)$(MANDIR)/man8/xinetd.log.8
++      rm -f $(DESTDIR)$(MANDIR)/man8/xinetd.8
++      rm -f $(DESTDIR)$(MANDIR)/man8/itox.8
+  
+ distclean: clean
+       rm -f config.cache config.log Makefile config.status xinetd/itox
diff --git a/package/xinetd/xinetd-003-rpc-fix.patch b/package/xinetd/xinetd-003-rpc-fix.patch
new file mode 100644 (file)
index 0000000..6c32b72
--- /dev/null
@@ -0,0 +1,26 @@
+This patch fixes compiling xinetd without RPC support.
+
+The content of this patch was copied from the OpenWrt project:
+https://dev.openwrt.org/browser/packages/net/xinetd/patches/003-rpc_fix.patch
+
+Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
+
+--- a/xinetd/confparse.c
++++ b/xinetd/confparse.c
+@@ -745,7 +745,7 @@ static status_e check_entry( struct serv
+          }
+    }
+-/* #ifndef NO_RPC */
++#ifndef NO_RPC
+ #if defined(HAVE_RPC_RPCENT_H) || defined(HAVE_NETDB_H)
+    if ( SC_IS_RPC( scp ) && !SC_IS_UNLISTED( scp ) )
+    {
+@@ -759,6 +759,7 @@ static status_e check_entry( struct serv
+       SC_RPCDATA( scp )->rd_program_number = rep->r_number ;
+    }
+    else
++#endif
+ #endif   /* ! NO_RPC */
+    {
+        if ( !SC_IS_UNLISTED( scp ) ) 
diff --git a/package/xinetd/xinetd-2.3.15/001-ar.patch b/package/xinetd/xinetd-2.3.15/001-ar.patch
deleted file mode 100644 (file)
index 566f2f7..0000000
+++ /dev/null
@@ -1,74 +0,0 @@
-This patch changes all of the hard-coded invocations of "ar" to $(AR), to
-support a cross-compilation toolchain.
-
-The content of this patch was copied from the OpenWrt project:
-https://dev.openwrt.org/browser/packages/net/xinetd/patches/001-ar.patch
-
-Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
-
---- a/libs/src/misc/Makefile.in
-+++ b/libs/src/misc/Makefile.in
-@@ -62,7 +62,7 @@
- $(LIBNAME): $(OBJECTS)
--      ar r $@ $?
-+      $(AR) r $@ $?
-       $(RANLIB) $@
- install: $(LIBNAME)
---- a/libs/src/portable/Makefile.in
-+++ b/libs/src/portable/Makefile.in
-@@ -57,7 +57,7 @@
- $(LIBNAME): $(OBJECTS)
--      ar r $@ $?
-+      $(AR) r $@ $?
-       $(RANLIB) $@
- install: $(LIBNAME)
---- a/libs/src/pset/Makefile.in
-+++ b/libs/src/pset/Makefile.in
-@@ -53,7 +53,7 @@
-       mv $(LIBNAME) $(LIBDIR)/optimized
- $(LIBNAME): $(OBJECTS)
--      ar r $@ $?
-+      $(AR) r $@ $?
-       $(RANLIB) $@
- install: $(LIBNAME)
---- a/libs/src/sio/Makefile.in
-+++ b/libs/src/sio/Makefile.in
-@@ -52,7 +52,7 @@
-       $(INSTALL) $(FMODE) $(LIBNAME) $(LIBDIR)/optimized
- $(LIBNAME): $(OBJECTS)
--      ar r $@ $?
-+      $(AR) r $@ $?
-       $(RANLIB) $@
- install: $(LIBNAME)
---- a/libs/src/str/Makefile.in
-+++ b/libs/src/str/Makefile.in
-@@ -63,7 +63,7 @@
-       $(INSTALL) $(FMODE) $(LIBNAME) $(LIBDIR)-O
- $(LIBNAME): $(OBJECTS)
--      ar r $@ $?
-+      $(AR) r $@ $?
-       $(RANLIB) $@
- LINT_IGNORE=possible pointer alignment|RCSid unused
---- a/libs/src/xlog/Makefile.in
-+++ b/libs/src/xlog/Makefile.in
-@@ -58,7 +58,7 @@
-       $(INSTALL) $(FMODE) $(LIBNAME) $(LIBDIR)/optimized
- $(LIBNAME): $(OBJECTS)
--      ar r $@ $?
-+      $(AR) r $@ $?
-       $(RANLIB) $@
- install: $(LIBNAME)
diff --git a/package/xinetd/xinetd-2.3.15/002-destdir.patch b/package/xinetd/xinetd-2.3.15/002-destdir.patch
deleted file mode 100644 (file)
index 7a323eb..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-This patch adds $(DESTDIR) to xinetd's installation paths, to support 
-installation to a cross-compiled RFS area.
-
-The content of this patch was inspired by the OpenWrt project:
-https://dev.openwrt.org/browser/packages/net/xinetd/patches/002-destdir.patch
-
-Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
-
-diff -urN xinetd-2.3.15.ORIG/Makefile.in xinetd-2.3.15/Makefile.in
---- xinetd-2.3.15.ORIG/Makefile.in     2007-09-20 13:01:52.000000000 -0400
-+++ xinetd-2.3.15/Makefile.in  2012-06-18 10:20:00.540864388 -0400
-@@ -75,27 +75,27 @@
- install: build
-       for i in $(DAEMONDIR) $(BINDIR) $(MANDIR)/man5 $(MANDIR)/man8 ; do \
--         test -d $$i || mkdir -p $$i ; done
--      $(INSTALL_CMD) -m 755 xinetd/xinetd $(DAEMONDIR)
--      $(INSTALL_CMD) -m 755 xinetd/itox $(DAEMONDIR)
--      $(INSTALL_CMD) -m 755 $(SRCDIR)/xinetd/xconv.pl $(DAEMONDIR)
--      $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.conf.man $(MANDIR)/man5/xinetd.conf.5
--      $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.log.man $(MANDIR)/man8/xinetd.log.8
--      $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.man $(MANDIR)/man8/xinetd.8
--      $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/itox.8 $(MANDIR)/man8/itox.8
--      $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xconv.pl.8 $(MANDIR)/man8/xconv.pl.8
-+         test -d $(DESTDIR)$$i || mkdir -p $(DESTDIR)$$i ; done
-+      $(INSTALL_CMD) -m 755 xinetd/xinetd $(DESTDIR)$(DAEMONDIR)
-+      $(INSTALL_CMD) -m 755 xinetd/itox $(DESTDIR)$(DAEMONDIR)
-+      $(INSTALL_CMD) -m 755 $(SRCDIR)/xinetd/xconv.pl $(DESTDIR)$(DAEMONDIR)
-+      $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.conf.man $(DESTDIR)$(MANDIR)/man5/xinetd.conf.5
-+      $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.log.man $(DESTDIR)$(MANDIR)/man8/xinetd.log.8
-+      $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.man $(DESTDIR)$(MANDIR)/man8/xinetd.8
-+      $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/itox.8 $(DESTDIR)$(MANDIR)/man8/itox.8
-+      $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xconv.pl.8 $(DESTDIR)$(MANDIR)/man8/xconv.pl.8
-       @echo "You must put your xinetd.conf in /etc/xinetd.conf"
-       @echo "There is a sample config file in xinetd/sample.conf and you can"
-       @echo "use xconv.pl to convert your old inetd.conf file to an xinetd format"
- uninstall:
--      rm -f $(DAEMONDIR)/xinetd
--      rm -f $(DAEMONDIR)/itox
--      rm -f $(DAEMONDIR)/xconv.pl
--      rm -f $(MANDIR)/man5/xinetd.conf.5
--      rm -f $(MANDIR)/man8/xinetd.log.8
--      rm -f $(MANDIR)/man8/xinetd.8
--      rm -f $(MANDIR)/man8/itox.8
-+      rm -f $(DESTDIR)$(DAEMONDIR)/xinetd
-+      rm -f $(DESTDIR)$(DAEMONDIR)/itox
-+      rm -f $(DESTDIR)$(DAEMONDIR)/xconv.pl
-+      rm -f $(DESTDIR)$(MANDIR)/man5/xinetd.conf.5
-+      rm -f $(DESTDIR)$(MANDIR)/man8/xinetd.log.8
-+      rm -f $(DESTDIR)$(MANDIR)/man8/xinetd.8
-+      rm -f $(DESTDIR)$(MANDIR)/man8/itox.8
-  
- distclean: clean
-       rm -f config.cache config.log Makefile config.status xinetd/itox
diff --git a/package/xinetd/xinetd-2.3.15/003-rpc_fix.patch b/package/xinetd/xinetd-2.3.15/003-rpc_fix.patch
deleted file mode 100644 (file)
index 6c32b72..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-This patch fixes compiling xinetd without RPC support.
-
-The content of this patch was copied from the OpenWrt project:
-https://dev.openwrt.org/browser/packages/net/xinetd/patches/003-rpc_fix.patch
-
-Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
-
---- a/xinetd/confparse.c
-+++ b/xinetd/confparse.c
-@@ -745,7 +745,7 @@ static status_e check_entry( struct serv
-          }
-    }
--/* #ifndef NO_RPC */
-+#ifndef NO_RPC
- #if defined(HAVE_RPC_RPCENT_H) || defined(HAVE_NETDB_H)
-    if ( SC_IS_RPC( scp ) && !SC_IS_UNLISTED( scp ) )
-    {
-@@ -759,6 +759,7 @@ static status_e check_entry( struct serv
-       SC_RPCDATA( scp )->rd_program_number = rep->r_number ;
-    }
-    else
-+#endif
- #endif   /* ! NO_RPC */
-    {
-        if ( !SC_IS_UNLISTED( scp ) )