python-cherrypy: new package
authorFrank Hunleth <fhunleth@troodon-software.com>
Sun, 8 Feb 2015 15:59:19 +0000 (10:59 -0500)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 23 Feb 2015 22:14:05 +0000 (23:14 +0100)
Signed-off-by: Frank Hunleth <fhunleth@troodon-software.com>
Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/python-cherrypy/Config.in [new file with mode: 0644]
package/python-cherrypy/python-cherrypy.hash [new file with mode: 0644]
package/python-cherrypy/python-cherrypy.mk [new file with mode: 0644]

index 2f90830d6820b661f7436dca5e2298a341846cd0..ceabce173120d1d3536fcd816a08a3642039210b 100644 (file)
@@ -514,6 +514,7 @@ menu "external python modules"
        source "package/python-certifi/Config.in"
        source "package/python-cffi/Config.in"
        source "package/python-cheetah/Config.in"
+       source "package/python-cherrypy/Config.in"
        source "package/python-coherence/Config.in"
        source "package/python-configobj/Config.in"
        source "package/python-configshell-fb/Config.in"
diff --git a/package/python-cherrypy/Config.in b/package/python-cherrypy/Config.in
new file mode 100644 (file)
index 0000000..6e32ec2
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_PYTHON_CHERRYPY
+       bool "python-cherrypy"
+       select BR2_PACKAGE_PYTHON_ZLIB if BR2_PACKAGE_PYTHON # runtime
+       select BR2_PACKAGE_PYTHON3_ZLIB if BR2_PACKAGE_PYTHON3 # runtime
+       select BR2_PACKAGE_PYTHON_PYEXPAT if BR2_PACKAGE_PYTHON # runtime
+       select BR2_PACKAGE_PYTHON3_PYEXPAT if BR2_PACKAGE_PYTHON3 # runtime
+       help
+         A minimalist web framework
+
+         http://www.cherrypy.org
diff --git a/package/python-cherrypy/python-cherrypy.hash b/package/python-cherrypy/python-cherrypy.hash
new file mode 100644 (file)
index 0000000..08fa075
--- /dev/null
@@ -0,0 +1,3 @@
+# md5 from https://pypi.python.org/pypi?:action=show_md5&digest=9772dbee426d656f01a13881e2b139d8, sha256 locally computed
+md5    9772dbee426d656f01a13881e2b139d8  CherryPy-3.6.0.tar.gz
+sha256 a149271819a15417104aa8f641ad5b96287070f0153e6ef2832a87e2c693d75d  CherryPy-3.6.0.tar.gz
diff --git a/package/python-cherrypy/python-cherrypy.mk b/package/python-cherrypy/python-cherrypy.mk
new file mode 100644 (file)
index 0000000..a08b21a
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-cherrypy
+#
+################################################################################
+
+PYTHON_CHERRYPY_VERSION = 3.6.0
+PYTHON_CHERRYPY_SOURCE = CherryPy-$(PYTHON_CHERRYPY_VERSION).tar.gz
+PYTHON_CHERRYPY_SITE = http://pypi.python.org/packages/source/C/CherryPy
+PYTHON_CHERRYPY_LICENSE = BSD-3c
+PYTHON_CHERRYPY_LICENSE_FILES = LICENSE.txt
+PYTHON_CHERRYPY_SETUP_TYPE = distutils
+
+$(eval $(python-package))