rsyslog: add 'else' clause to mysql and postgresql support
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 14 Jan 2015 21:07:14 +0000 (22:07 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 14 Jan 2015 21:07:14 +0000 (22:07 +0100)
Having 'else' clauses handling the absence of mysql and postgresql
support to explicitly disable such features helps to avoid
misdetection of system-installed packages.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/rsyslog/rsyslog.mk

index fe28d2fcd7e4487889bd12a39dce40f2b8471010..1e0953f83f1badfd380104b4aae0bc36ce17c70f 100644 (file)
@@ -40,12 +40,16 @@ ifeq ($(BR2_PACKAGE_MYSQL),y)
 RSYSLOG_DEPENDENCIES += mysql
 RSYSLOG_CONF_OPTS += --enable-mysql
 RSYSLOG_CONF_ENV += ac_cv_prog_MYSQL_CONFIG=$(STAGING_DIR)/usr/bin/mysql_config
+else
+RSYSLOG_CONF_OPTS += --disable-mysql
 endif
 
 ifeq ($(BR2_PACKAGE_POSTGRESQL),y)
 RSYSLOG_DEPENDENCIES += postgresql
 RSYSLOG_CONF_OPTS += --enable-pgsql
 RSYSLOG_CONF_ENV += ac_cv_prog_PG_CONFIG=$(STAGING_DIR)/usr/bin/pg_config
+else
+RSYSLOG_CONF_OPTS += --disable-pgsql
 endif
 
 ifeq ($(BR2_PACKAGE_UTIL_LINUX_LIBUUID),y)