qt: remove the BR2_PACKAGE_QT_JAVASCRIPTCORE option
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 7 Nov 2013 19:07:21 +0000 (20:07 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 10 Nov 2013 11:11:01 +0000 (12:11 +0100)
The BR2_PACKAGE_QT_JAVASCRIPTCORE option was available to force the
activation or disabling of the JIT compiler in the Qt Javascript
interpreter. However, the JIT compiler is not available for all
architectures, so forcing its activation does not always
work. Moreover, Qt knows by itself for which architectures JIT support
is possible, and will automatically enable it if possible.

Therefore, this option was in fact useless, and causing build problems
when enabled on architectures for which the JIT support was not
available. This commit removes this option and there is no
replacement: Qt will enable JIT at compile time when possible.

Fixes:

  http://autobuild.buildroot.org/results/aae/aaeb82753b7654eeca679ded5d0211ceebda3ea2/build-end.log
  http://autobuild.buildroot.org/results/367/3670e4f03ff0ce114c90bd7139243d82c427b52a/build-end.log

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in.legacy
package/qt/Config.in
package/qt/qt.mk

index 588cd8bf721f0c870e9ce46ecea1869c164c4d46..d02f0a6386819e5af70eb16a350cee76eb3d4725 100644 (file)
@@ -101,6 +101,24 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2013.11"
 
+config BR2_PACKAGE_QT_JAVASCRIPTCORE
+       bool "qt javascriptcore option removed"
+       select BR2_LEGACY
+       help
+         The BR2_PACKAGE_QT_JAVASCRIPTCORE option was available to
+         force the activation or disabling of the JIT compiler in the
+         Qt Javascript interpreter. However, the JIT compiler is not
+         available for all architectures, so forcing its activation
+         does not always work. Moreover, Qt knows by itself for which
+         architectures JIT support is possible, and will
+         automatically enable it if possible.
+
+         Therefore, this option was in fact useless, and causing
+         build problems when enabled on architectures for which the
+         JIT support was not available. It has been removed, and
+         there is no replacement: Qt will enable JIT at compile time
+         when possible.
+
 config BR2_PACKAGE_MODULE_INIT_TOOLS
        bool "module-init-tools replaced by kmod"
        select BR2_PACKAGE_KMOD
index ea9e787de43d1299d92a9e7cdab29b7411161d8f..b1a2207f23165dc0c165bf9a78fe57ce6d5e6f47 100644 (file)
@@ -365,12 +365,6 @@ comment "WebKit needs shared library/gui/network support"
        depends on !(BR2_PACKAGE_QT_SHARED && BR2_PACKAGE_QT_GUI_MODULE && BR2_PACKAGE_QT_NETWORK)
        depends on BR2_PACKAGE_QT_ARCH_SUPPORTS_WEBKIT
 
-config BR2_PACKAGE_QT_JAVASCRIPTCORE
-       bool "JavaScriptCore JIT compiler"
-       help
-         Build the JavaScriptCore JIT compiler
-         If unsure, say y
-
 config BR2_PACKAGE_QT_STL
        bool "STL support"
        help
index 48d39fc50140fb2d353757fb14d9684accb609fd..82ce51dbd045c61abfeb53793f5a0013c27325d8 100644 (file)
@@ -415,12 +415,6 @@ else
 QT_CONFIGURE_OPTS += -no-scripttools
 endif
 
-ifeq ($(BR2_PACKAGE_QT_JAVASCRIPTCORE),y)
-QT_CONFIGURE_OPTS += -javascript-jit
-else
-QT_CONFIGURE_OPTS += -no-javascript-jit
-endif
-
 ifeq ($(BR2_PACKAGE_QT_STL),y)
 QT_CONFIGURE_OPTS += -stl
 else