host-qemu: needs host-python
authorPeter Korsgaard <peter@korsgaard.com>
Fri, 6 Feb 2015 10:36:25 +0000 (11:36 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 6 Feb 2015 10:36:25 +0000 (11:36 +0100)
Fixes:
http://autobuild.buildroot.net/results/e58/e58a0d7d5c084be000ae7d5b3821cd68d6639aab/
http://autobuild.buildroot.net/results/624/62425cfdd4270bf1a9b15bd57490478b1c04c720/
http://autobuild.buildroot.net/results/d18/d189d7f75ffbb3349b68a5c312b14ea5638bb903/
http://autobuild.buildroot.net/results/7d3/7d386322cec452ee636adb20be0c1a31f38385fc/

And many more.

Just like qemu for the target, host-qemu needs python (2.x) on the host.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/qemu/qemu.mk

index 6c5ddf3357fdd874596e15a0093db4418773e30e..259813ccbd40ab8f09c70ac962a018792debc0cf 100644 (file)
@@ -16,7 +16,7 @@ QEMU_LICENSE_FILES = COPYING COPYING.LIB
 #-------------------------------------------------------------
 # Host-qemu
 
-HOST_QEMU_DEPENDENCIES = host-pkgconf host-zlib host-libglib2 host-pixman
+HOST_QEMU_DEPENDENCIES = host-pkgconf host-python host-zlib host-libglib2 host-pixman
 
 #       BR ARCH         qemu
 #       -------         ----
@@ -94,6 +94,7 @@ define HOST_QEMU_CONFIGURE_CMDS
                --interp-prefix=$(STAGING_DIR)          \
                --cc="$(HOSTCC)"                        \
                --host-cc="$(HOSTCC)"                   \
+               --python=$(HOST_DIR)/usr/bin/python2    \
                --extra-cflags="$(HOST_CFLAGS)"         \
                --extra-ldflags="$(HOST_LDFLAGS)"
 endef