iptables: fix disable-ipv6 option
authorOlaf Rempel <razzor@kopf-tisch.de>
Sun, 20 Sep 2009 11:54:02 +0000 (13:54 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 20 Sep 2009 12:44:12 +0000 (14:44 +0200)
- bumb version to v1.4.5
- add fix for --disable-ipv6 option
  (upstream bug: http://bugzilla.netfilter.org/show_bug.cgi?id=608)

Signed-off-by: Olaf Rempel <razzor@kopf-tisch.de>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/iptables/iptables-1.4.5-disable-ipv6.patch [new file with mode: 0644]
package/iptables/iptables.mk

diff --git a/package/iptables/iptables-1.4.5-disable-ipv6.patch b/package/iptables/iptables-1.4.5-disable-ipv6.patch
new file mode 100644 (file)
index 0000000..9f22a0c
--- /dev/null
@@ -0,0 +1,19 @@
+--- iptables-1.4.5/xtables.c.org       2009-09-14 18:36:55.000000000 +0200
++++ iptables-1.4.5/xtables.c   2009-09-20 13:24:11.000000000 +0200
+@@ -1484,6 +1484,7 @@
+ xtables_ip6parse_multiple(const char *name, struct in6_addr **addrpp,
+                     struct in6_addr **maskpp, unsigned int *naddrs)
+ {
++      static const struct in6_addr zero_addr;
+       struct in6_addr *addrp;
+       char buf[256], *p;
+       unsigned int len, i, j, n, count = 1;
+@@ -1526,7 +1527,7 @@
+               memcpy(*maskpp + i, addrp, sizeof(*addrp));
+               /* if a null mask is given, the name is ignored, like in "any/0" */
+-              if (memcmp(*maskpp + i, &in6addr_any, sizeof(in6addr_any)) == 0)
++              if (memcmp(*maskpp + i, &zero_addr, sizeof(zero_addr)) == 0)
+                       strcpy(buf, "::");
+               addrp = ip6parse_hostnetwork(buf, &n);
index 48e5d3344ea5c1b3040292067e85f951bbd894ac..1c3d9bed9ddfc4a1f2aafe992fc48300ddcd527f 100644 (file)
@@ -3,7 +3,7 @@
 # iptables
 #
 #############################################################
-IPTABLES_VERSION = 1.4.4
+IPTABLES_VERSION = 1.4.5
 IPTABLES_SOURCE = iptables-$(IPTABLES_VERSION).tar.bz2
 IPTABLES_SITE = http://ftp.netfilter.org/pub/iptables