xapp_xditview: fix build with pkgconf 1.5.3
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 14 Dec 2018 15:29:34 +0000 (16:29 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 14 Dec 2018 20:24:14 +0000 (21:24 +0100)
Since the bump to 1.5.3, pkgconf prepends the sysroot to all absolute
paths found in the .pc file. This is correct when the paths refer to
something in STAGING_DIR (e.g. libdir, includedir), but not when it
refers to something used for the target.

xapp_xditview uses the appdefaultdir variable from xt.pc to decide where
to install things. Since DESTDIR is prepended to the install
destination, this will end up in the wrong location.

Until a better solution is found in pkgconf, pass the appdefaultdir to
use explicitly instead of relying on xt.pc.

Fixes:
 - http://autobuild.buildroot.org/results/af70962c59ca3dd29d85207033125b2e7eda3e81

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/x11r7/xapp_xditview/xapp_xditview.mk

index 4744c1fefd8d8ec06b9c81adda4476b8b3369c4c..e8d72770ea4a9222d4e30e349c74b7bcd00b0c0a 100644 (file)
@@ -10,5 +10,6 @@ XAPP_XDITVIEW_SITE = http://xorg.freedesktop.org/releases/individual/app
 XAPP_XDITVIEW_LICENSE = MIT
 XAPP_XDITVIEW_LICENSE_FILES = COPYING
 XAPP_XDITVIEW_DEPENDENCIES = xlib_libXaw
+XAPP_XDITVIEW_CONF_OPTS = --with-appdefaultdir=/usr/share/X11/app-defaults
 
 $(eval $(autotools-package))