psmic: locale support
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 25 Aug 2008 09:05:00 +0000 (09:05 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 25 Aug 2008 09:05:00 +0000 (09:05 -0000)
Closes #4274.

package/psmisc/Config.in
package/psmisc/psmisc.mk

index a9f71b95439b2690a1bc35d72f30fee6be563669..e7ce7046192dc438cd3e3a5f16645f39a94601e4 100644 (file)
@@ -1,6 +1,8 @@
 config BR2_PACKAGE_PSMISC
        bool "psmisc"
        select BR2_PACKAGE_NCURSES
+       select BR2_PACKAGE_GETTEXT if BR2_ENABLE_LOCALE
+       select BR2_PACKAGE_LIBINTL if BR2_ENABLE_LOCALE
        help
          Helpful /proc related utilities such as pstree, fuser, and killall
 
index b2ec834f962cee603485cc6c81b91727940d000e..e89214748786d71c07dc7999da2b3b43eed1a633 100644 (file)
@@ -15,4 +15,10 @@ PSMISC_CONF_ENV:=ac_cv_func_malloc_0_nonnull=yes \
 PSMISC_CONF_OPT:= $(DISABLE_NLS) $(DISABLE_IPV6)
 PSMISC_DEPENDENCIES:=uclibc ncurses
 
+ifeq ($(BR2_ENABLE_LOCALE),y)
+# psmisc gets confused and forgets to link with libintl
+PSMISC_MAKE_OPT:=LIBS=-lintl
+PSMISC_DEPENDENCIES+= gettext libintl
+endif
+
 $(eval $(call AUTOTARGETS,package,psmisc))