ntfs-3g: needs libgcrypt
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 28 Dec 2012 09:47:20 +0000 (09:47 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 28 Dec 2012 20:55:49 +0000 (21:55 +0100)
Now that we've moved to gnutls 3.x which no longer uses libgcrypt we
need to pull it in as a dependency for ntfs-3g encrypted volume support
to avoid build breakage.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/ntfs-3g/Config.in
package/ntfs-3g/ntfs-3g.mk

index 5301038896b1c036bb54ec9656f5cdae4b81c5da..1d3e2fb9bd87ce79845219943fc938ede3ca080b 100644 (file)
@@ -17,6 +17,7 @@ if BR2_PACKAGE_NTFS_3G
 config BR2_PACKAGE_NTFS_3G_ENCRYPTED
        bool "encrypted volumes"
        select BR2_PACKAGE_GNUTLS
+       select BR2_PACKAGE_LIBGCRYPT
        help
          Enable support for NTFS encrypted volumes.
 
index d2e68611d282eda86b6b76de1554e0a184c6791d..cefb73a40d897faccfdc0b3c7a69249d818f935a 100644 (file)
@@ -23,7 +23,7 @@ endif
 ifeq ($(BR2_PACKAGE_NTFS_3G_ENCRYPTED),y)
        NTFS_3G_CONF_ENV += LIBGCRYPT_CONFIG=$(STAGING_DIR)/usr/bin/libgcrypt-config
        NTFS_3G_CONF_OPT += --enable-crypto
-       NTFS_3G_DEPENDENCIES += gnutls
+       NTFS_3G_DEPENDENCIES += gnutls libgcrypt
 endif
 
 ifneq ($(BR2_PACKAGE_NTFS_3G_NTFSPROGS),y)