Makefile: do not purge locale-archive from target
authorSven Neumann <neumann@teufel.de>
Wed, 18 Jun 2014 09:23:30 +0000 (11:23 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 15 Jul 2014 20:56:23 +0000 (22:56 +0200)
The rules to purge unwanted locales from the target also removed
the locale-archive file from /usr/lib/locale which contains the
locale definitions explicitly generated for the target.

Signed-off-by: Sven Neumann <neumann@teufel.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Makefile

index b3bd91eb54d4375cc22a65dc8d9b70be52be02f8..1af51de50650cf9b9f1aa3dfe43ed7674681e050 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -538,7 +538,7 @@ LOCALE_NOPURGE = $(call qstrip,$(BR2_ENABLE_LOCALE_WHITELIST))
 
 define PURGE_LOCALES
        rm -f $(LOCALE_WHITELIST)
-       for i in $(LOCALE_NOPURGE); do echo $$i >> $(LOCALE_WHITELIST); done
+       for i in $(LOCALE_NOPURGE) locale-archive; do echo $$i >> $(LOCALE_WHITELIST); done
 
        for dir in $(wildcard $(addprefix $(TARGET_DIR),/usr/share/locale /usr/share/X11/locale /usr/man /usr/share/man /usr/lib/locale)); \
        do \